Unnamed strange problem (v7.2.2 and previous)

  • Since same file is opened in second tab I wonder what do you see when you scroll to same location there.

    I will check it next time.

    What plugins do you have installed?

    Compare, Converter, MIME Tools, NppExec, NppExport

    How often does it happen?

    Not really often, maybe every ~10 coding seances. But enough to be annoying.

    If you re-ecnode file to UTF8, can you still reproduce this issue?

    I don’t know how to reproduce this. I have only a guess that this caused by two tabs of the same document + ‘{’ symbol + enter. Maybe this bug caused by auto-tabulation?

    Does it also happen with smaller files?

    It never happened with smaller files. But i work really rarely with smaller files and never in two tabs.

    After it happens if you “save as” to different name, relaunch npp and open it, is the file corrupted?

    I’ll check next time. But i think no, because when this appears with document on screenshot, i just press Ctrl+Z for a few times, reload Notepad (without saving), and then document looks OK, except two tabs doesn’t synced and behave like two different documents! Then i got to choose, which of them i need to save, and which to close “without saving”.

    There is also one thing that maybe could help. When i scroll document at the end, there is a “}” brace, that added automatically. And as i remember, it adds only to one of tabs. I’ll try to check it next time when bug appears.

  • Turn off periodic backups. It is known to corrupt large files.

  • @dail said:

    Turn off periodic backups. It is known to corrupt large files.

    Can you tell me or better show a screenshot where exactly i got to do that? Because looks like it disabled now.

  • Settings > Preferences > Backup > Enable session snapshot and periodic backups

  • @dail well… periodic backups were always disabled for me, so this is not a reason. Only session snapshot is enabled.

  • At least two other people have confirmed this bug.

  • I taped a bit of coding process and here what i got https://www.youtube.com/watch?v=Y-obRpiFlcQ
    This thing happened to me for a few times today…

  • @gstavi Hey.

    I deleted all plugins except NppExec. Guess what i got today? Watch this video https://www.youtube.com/watch?v=bZB2cRFAAHY
    So… will it be fixed?

  • @stabker-steepson

    Only session snapshot is enabled.

    As I said before make sure to turn off session snapshot.

    Here is a reproducible test case for this bug:

    1. Open a file from disc
    2. Clone the file to the other view
    3. Make sure “Remember Current Session” is enabled
    4. Make sure “Session snapshot and periodic backup” is enabled
    5. Leave the file in an unsaved state
    6. Restart N++
    7. Observe that the files are no longer in “sync” when they are edited

    Note: If at step 4 “Session snapshot and periodic backup” is disabled, the everything works fine.

  • @dail thx, seems like you’re right. I have been disabled all items and everything is alright.

Log in to reply