Set Notepad++ as default app in Windows 10



  • New to Win 10. could not change the default file extension of .txt file from Notepad to Notepad++.
    appreciate step by step instructions.



  • Cannot get it to work via regular path, from within Notepad++ or through Windows System Setting default programs. I opened admin command prompt, started notepad++ from there and updated the file association setting. Then it worked.



  • forgot to mention:
    Windows 1607 14393.576 64-bit
    Notepad++ v7.3 64-bit



  • Gotta LOVE how windows tries to muscle out the competition!

    Okay, here is a work around:

    1. Create a dummy file with the extension you wish to default to your program. The file can be empty.
    2. Right click on the dummy file and select Properties.
    3. On the General tab there is a section that states:
      Type of file: <YOUR_SUFFIX>
      Opens with <CURRENT_DEFAULT_PROGRAM> and a button that says <CHANGE>.
    4. Click Change.
    5. How do you want to open <YOUR_SUFFIX> files from now on? Choose <More apps>.
    6. Scroll to the bottom and select <Look for another app on this PC>
    7. Go to C:\Program Files (x86)\Notepad++ and select <notepad++.exe> and select <OPEN>
    8. Close Properties and your done!


  • You’re a lifesaver! Thanks!



  • Another way to set Notepad++ as default app in Windows 10 is outlined in Trish Tech [source].

    Basically, when you install Notepad++, go to Settings > Preferences > File Association, select Notepad. Then move the .txt and .log extensions to Registered extensions. Close the dialogue, close Notepad++. Right-click on any .txt file > Open with… > select Notepad++

    That’s it.

    Could be a bit easier for some people compared to the option Kent provided.



  • I had to install Notepad++ Fork from Windows 10 store:
    https://www.microsoft.com/en-us/store/p/notepad-fork/9plhc123mqwt
    to make all mentioned methods work:/
    Standard version of Notepad++ was installed on my PC and it just seems to allows me to connect N++ to Windows :)
    After installing it, restart PC. Then right click on the file and either chose default app as it was in previous Windows 8.1 or go to file properties and then Change.



  • I am working within a Domain as a user with no administrator privileges (but I have the password).

    I had to combine Kents and elnahirs answers to succeed:

    Start Notepad++ with elevated rights, go to Settings > Preferences > File Association, select Notepad. Then move the .txt and .log extensions to Registered extensions. Close the dialogue, close Notepad++.

    Then follow Kent:
    @Kent-Lasley said:

    1. Create a dummy file with the extension you wish to default to your program. The file can be empty.
    2. Right click on the dummy file and select Properties.
    3. On the General tab there is a section that states:
      Type of file: <YOUR_SUFFIX>
      Opens with <CURRENT_DEFAULT_PROGRAM> and a button that says <CHANGE>.
    4. Click Change.
    5. How do you want to open <YOUR_SUFFIX> files from now on? Choose <More apps>.
    6. Scroll to the bottom and select <Look for another app on this PC>
    7. Go to C:\Program Files (x86)\Notepad++ and select <notepad++.exe> and select <OPEN>
    8. Close Properties and your done!


  • @Mark-Warkentin

    Your are using Windows 10 1803? There seems to be a bug introduced with the 2018-10 Windows updates, see here.



  • I’m using Windows 10 1803 as well, but managed to get the file associate changed. I’m not sure what did it though, as I tried setting through Notepad++, in the Win 10 App settings, through the registry (I was desperate).

    Notepad++ finally showed up as something to select and after a reboot, it seems like it’s my default now. I personally don’t care about the how since it works finally, but if I come across it again on another machine before 1809 is re-released, I’ll test and document better to share.



  • POSSIBLY, this could be an issue with 32-bit vs. 64-bit. I completely missed there was a 64-bit download available for a long time; I just didn’t think about it.

    I stumbled on their being a 64-bit download, grabbed that, removed the 32-bit version and installed 64-bit. I ran it, altered settings for Text and it failed. I ran it again as Administrator, altered settings for Text and things are opening in Notepad++ now.



  • I resolved this by manually registering the file extensions in Notepad++ preferences.

    1. Run Notepad++ as administrator
    2. Go to Settings > Preferences > File Association
    3. Select Notepad “.txt” in Supported extensions panel
    4. Click the "-> " to move it to Registered extensions panel
    5. Close and try to reassociate


  • @Jason-M-Fruge Your solution worked for me. Thanks.


Log in to reply