Help with displaying Korean characters



  • Adopting my wife’s computer (laptop failure), I found that with the latest version of Notepad++, I can’t get Korean characters to display. I’ve tried different options like UTF+BOM, ANSI, etc to no avail. 너에게 닿기를 displays just fine in Notepad, but all I get is boxes or question marks in Notepad++. How do I make it display correctly in 7.3?

    NOTE: I am not typing in Korean, I’m copy/pasting.

    Thanks in advance for answers!



  • @Eric-Wirsing

    please be referred to the post Peter Jones wrote.
    I assume it is the same issue.

    Cheers
    Claudia



  • Similar to this post, are you certain the font you have selected for NPP has the Korean characters? Preferences > Style Configurator > Global Styles > Default Style > Font Style will tell you what font is chosen for NPP as default.

    To see whether that font has the Korean characters, WIN+R (windows button and R at the same time) > charmap, select that same font from the pulldown; select Group By = Unicode Subrange, and in the Group By popup window, select the appropriate Korean group (Korean Hangul, I assume). Note that the DejaVu Mono that I recommended in the Greek post doesn’t have any characters in the Korean Hangul group; however, Source Code Pro does have some characters in that group, though I cannot say whether it’s all that you need or not.

    Hmm, actually, when I copy your " 너에게 닿기를" into my NPP with DejaVu Mono font, those characters do show up, so maybe that’s not the right Unicode Subrange to look at (I know nothing about Korean characters). I looked at my windows notepad.exe font setting, and it’s Lucida Console, so if you don’t have (or don’t want) DejaVu Mono or Source Code Pro, you might try Lucida Console (or whatever your notepad > format > font is set to).


Log in to reply