Changelog opens every time I start NPP



  • The changelog appears on a tab in NPP every time I open the program. If I close the tab and restart the program, it returns. Is there a setting I’m missing or is this a bug?



  • @mcgregormedia

    that’s strange - if you explicitly close the file it shouldn’t reopen on next startup.
    If you just close npp, then yes, it might reappear if you have
    Settings->Preferences->Backup->Remember current session for next launch activated.
    Which makes me think that you have no write access to the file session.xml which holds
    that kind of information. (Either under %APPDATA%\notepad++ or installation directory)

    Cheers
    Claudia



  • I’ve got the same issue, and the write permissions to %APPDATA%\notepad++ seem ok. How do I manually edit session.xml to make the change.log file go away?



  • @thecoop

    temporarily, rename session.xml - start npp - is it gone?

    Cheers
    Claudia



  • Nope - still appears, and a new session.xml is not created on startup

    EDIT: I think I’ve figured out what it is - I pinned NPP to the taskbar when I first started it up, when the change.log file was open. This made windows pin that file specifically, rather than just starting NPP. So when I started it by clicking the icon, I was opening change.log within NPP



  • @thecoop

    afaik, session.xml gets created when closing npp.
    If it still appears than it means that you either have edited the wrong file
    (it could be in two places, depending on your configuration) or it
    isn’t in the the session.xml file at all. Strange.
    Could you show your debug-info?
    Available under menu ?

    Cheers
    Claudia



  • @thecoop

    aahhh - this is a good one ;-))))

    Cheers
    Claudia



  • Hmmm, which makes me thinking if npp gets updated - might it restart with command line parameter
    set to load changes.log file??

    @thecoop
    could you see if your link (shortcut) has set this parameter?

    Cheers
    Claudia



  • Yup - pinning the instance of Notepad++ that is opened by the installer uses a shortcut target of:

    "C:\Program Files\Notepad++\notepad++.exe" C:\Program Files\Notepad++\change.log


  • @thecoop

    thank you very much.
    Now we need to find out if and how this can be prevented by npp.

    Cheers
    Claudia



  • @thecoop Can’t thank you enough for figuring this out and posting the solution, it was driving me nuts.



  • @thecoop FWIW, I closed all open files, unpinned NP++, re-opened it with no files, then re-pinned it. Thanks.



  • Please Try It

    Delete Your Notepad++ shortcut
    &
    Run from => Start Menu > All Programs > Notepad++

    I did this.



  • Mutlu Erkol, Thanks i did the same and got rid of this.

    Guys,
    if someone facing this issue, just delete that shortcut by closing that change.log file and again open from start, then that chage.log file will be dissapeared.
    after that u can make it as a shortcut anywhere :).

    Cheers,
    Vinoth RN



  • YES!!! Thank you very much! I had the same issue myself. Even after deleting the file, then I had a message about a new file constantly popping up. Very annoying! It’s fixed now though. :)



  • This was driving me a little crazy too, so I found and deleted change.log. Then NPP 7.3.3 informed me on each NPP start up that the change.log file was missing. NPP did this over two prompts, (1) Is it OK to build C:\Program? (2) is it OK to build File? I denied NPP a few days, and finally gave in to let it just build the darned files. Well somehow C:\Program was built as a 0KB file, owned by <computername>\Administrators, and I can’t touch it. It seems to be impacting elder apps (e.g. old Cisco VPN still in use). I have a hunch that C:\Program is getting in the way of path C:\Program Files… Windows is prompting me on every boot if it can rename this file, but even the boot process can’t touch C:\Program. (This is a corporate laptop and I’ve Googled and attempted many possible treatments to remove. My help desk seems stumped too.)



  • @thecoop thanks a lot! I deleted ‘C:\Program Files\Notepad++\change.log’ from the shortcut and it worked.



  • This was bothering me to no end. Thanks for the solution!



  • Thanks for the solution! If you’ve pinned to the taskbar you can right click on the NPP icon, select properties, and remove the changelog path in the target field. You don’t have to delete the link with this ;)!



  • @thecoop - Thank you for saving my sanity. You’re the hero that gotham needs…


Log in to reply