Save As ... always maximizes window



  • I use Save As … pretty much daily with Notepad ++ so that I can change the location of the file. I noticed that the window for Save As … is always maximized such that it covers the entire screen and there is no option to resize or move the window.

    This makes it difficult when I need to look at another file – for example to remember a naming convention that I haven’t had to use in while.

    I distinctly remember this not being the case a while back, but not sure exactly when it changed. I upgraded to the current release 7.2.2 but this issue is still there.

    Is there a workaround? Anyone else remember this not being the case previously or is that wishful thinking on my part? Thx, SDK



  • @SDKBoston

    right click into the window title location where save as appears.
    There must be something like resize - can’t really remember what windows used.

    Cheers
    Claudia



  • I have the same issue, and on my 27-inch monitor it’s is annoying. There seems to be no way to change it. I have looked everywhere. Can something be done?



  • @Suellen-H.-Slockbower

    what about my comment on this?

    Cheers
    Claudia



  • @Suellen-H.-Slockbower,

    To expand on @Claudia-Frank’s answer, this is typical behavior for a maximized Save As, not just Notepad++ behavior. When the Save As dialog is open, right click on the Title Bar. If it’s truly Maximized, you should see something like

    where you can select Restore. You may have to resize it, even after it’s not maximized. If you cannot get your mouse to grab one of the edges in a normal Windows resize, you should be able to right click on the Title Bar again, this time seeing something like

    where Restore is greyed out; you can then select Size to try to resize the window: it will give the four-arrow mouse pointer, and you can grab one of the edges to resize.

    Additionally, when you open Save As, you might see the dotted-triangle in the lower-right corner:

    If you try to grab that corner, and it’s truly Maximized, nothing will happen to the window size… but the dotted corner will turn into a plain corner:

    That will indicate it’s truly maximized, so you should be able to do the Title Bar > RClick > Restore to get into a resizeable mode.


    Aside: googling for “save as won’t un-maximize” gave results where the first answer would have solved it for you.



  • You can flip a window in/out of maximized mode by double clicking on the title bar. That works for the Save-As window too. Windows itself remembers the Save and Save-As window position and size for each application. Unfortunately, while it’s in the registry the data is buried in a blob within HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\CIDSizeMRU meaning it’s not easy to go in and reset an app to the defaults.

    If you ever are jammed and can’t see or get to the top of a window then do Alt-spacebar. You should get the same menu that you get when you use the mouse to click on the upper-left corner of an application. This trick works even if the window is dragged 100% off the screen and is not visible. You will then have either “Restore” available if the window is currently maximized or “Size, Move, and Maximize” options Using this menu you can also move and resize a window using the arrow keys to drag it back on screen if needed.


Log in to reply