Is it possible to a xml-file without xml-support?



  • hi
    my problem:
    I have some very big xml-files: with some gigabytes or bigger.
    Everytime, I want to load those (also or smaller) xml-files, the computer works heavy. sometimes it wants not to load the very big(ger) xml-files. sometimes it loads. but WITH xml-support, which I don’t want.

    My question: I don’t want, while loading, an identifying as an xml.file. I don’t want a help on screen (right with minussigns or plussigns). Is it possible to get a file loading as “naked” in notepadd+±editor?

    Thanks a lot of helping me.
    Yours Klaus



  • @Klaus-Lehmann

    Perhaps this is a really obvious answer, but couldn’t you rename the extension part of the filename from .xml to .txt before opening the “big” files? :-D



  • good idea! I’ve never thought about this possibility ;-)
    (really!)
    some seconds later. it doesn’t work.
    copy *.xml *.ttt
    notepad++ interpretes the 1(?)st line:
    “<?xml version=“1.0” encoding=“UTF-8”?>”

    and gives his own interpretation, as an xml-file.
    great idea!

    but if we do THIS:
    kill 1st line: “<?xml version=“1.0” encoding=“UTF-8”?>”
    and than edit with notepad++, than it will works!
    hm…

    if there’s not another solution, than would this works. ok.
    I’m sure, there must exist something, in settings? in commandline? to ignore xml-function… it would be very lovely!

    thanks a lot for Your ideas
    yours Klaus



  • go to plugins,
    and if you have “xml tools” installed,
    then turn off the “xml syntax auto-check”



  • thanks JsjS,
    it seems to be a good idea ;-)
    but I have no plugins.
    this is a standard installtion with “Converter” and “MIME-Tools”.
    Yours, Klaus



  • this may work

    Settings … Preferences … Language … Language Menu … disable XML

    restart NPP

    also try running NPP with -noPlugin switch

    if you use windows, make a shortcut to NPP on your desktop

    right click the shortcut icon … choose “properties” from context menu

    edit “Target” entry by adding " -noPlugin" (without quotes)

    mine is: E:\apps\Notepad++\notepad++.exe -noPlugin

    then just drag and drop xml file onto the shortcut icon

    see if that makes a difference.



  • Hello, @klaus-lehmann, @js-js and All,

    Sorry for this very late reply, but I just tested, with N++ v7.5.6, the following method and it works nice ;-))

    • Open a DOS console window

    • With an appropriate cd /d DOS command, followed by the absolute path of Notepad++, in order to move to the installation folder of N++

    • Then, type the command notepad++ -nosession -lnormal <Absolute Path ofYour_BIG_file.xml>

    • After hitting the Enter key, Notepad++ should start with, only, the Your_BIG_file.xml file, as it was a simple .txt file !

    Best Regards,

    guy038



  • Hello @guy038 . thank You very much for Your good idea! this is the solution!

    in my nortoncommander-clone from Australia: “FCW” I have added in fc.ini:
    [Editor Associations]
    *.{xml}: “c:\Program Files\Notepad++ allegro\notepad++.exe” -nosession -lnormal

    good solution! thanks a lot!


Log in to reply