How to stop Notepad++ intercepting back/forward keypresses?



  • I have just updated to Notepad++ 7.2.2, and I’m running on Windows 10.

    I have a Microsoft keyboard with specific “Back” and “Forward” keys, which are usually mapped to Back/Forward in web browsers, etc. I have remapped them to change virtual desktops in Windows 10, and I use them a lot.

    Notepad++ seems to be intercepting these key presses, and uses them to change to previous/next tab. So, if Notepad++ has focus, I cannot change virtual desktop with those keys.

    How can I stop Notepad++ intercepting the key presses? I have tried clearing the keyboard shortcuts for next/previous tab, but that had no effect. I guess the back/forward button thing is more of a mouse shortcut than a keyboard shortcut, but I can’t find any option to disable the mouse shortcut either.



  • Are you sure it is next/previous tab and not something similar?
    You need to figure out exactly what is the key sequence that is being sent by the keyboard sofware.
    It may be trigger a plugin shortcut rather than global shortcut.



  • @gstavi
    Thanks for the response. I tried to find out the key code that was being generated, but with no luck.

    However, I have actually resolved my issue. It appears that notepad++ only intercepts the keys when being run as administrator. Not sure why that makes a difference, but I closed and re-opened with normal user privileges and it no longer intercepts it; ie I can change virtual desktops again.


Log in to reply