Set user-defined language as default?



  • I would like to set a user-defined language as the default language. It isn’t listed in the available options on the Default Language dropdown. Is this possible?



  • @Mike-Schmidt

    Afaik, not natively possible but I described a possible workaround here.

    Cheers
    Claudia



  • Thanks Claudia, but I could not get it to work. I followed your instructions exactly. I even tried it multiple times to make sure I wasn’t missing something (which I certainly may still be.)

    Does it matter where the python script is saved? Here is where my “startup.py” is saved:
    Notepad ++\plugins\Config\PythonScript\scripts



  • @Mike-Schmidt

    Did you install the python script plugin via plugin manager or via the msi package?
    If you open the python script console - what gets displayed?
    Did you restart npp?

    Cheers
    Claudia



  • OK…I did almost everything you said.

    I didn’t install the MSI because I’m on my work PC and don’t have Admin rights. Is there a manual install option?

    Here is what is displayed in Python console:
    Python 2.7.6-notepad++ r2 (default, Apr 21 2014, 19:26:54) [MSC v.1600 32 bit (Intel)]
    Initialisation took 125ms
    Ready.

    Yes, I restarted NPP.

    Thank you very much for the help!



  • OK - looks good - you are one of the lucky users where install via plugin manager worked.

    Just to check that everything works as expected please type the following into the
    textbox next to the run button

    print '\n'.join(dir(editor))
    

    Does this work?

    Cheers
    Claudia



  • If you get a similar result as I have,
    try to open a document with your udl and see if something
    is reported in the console.

    Cheers
    Claudia



  • Here is where my “startup.py” is saved: Notepad ++\plugins\Config\PythonScript\scripts

    Sorry missed that - it depends how npp was installed.
    If local configuration is used then it is saved in INSTALL_DIR\plugins\Config\PythonScript\scripts
    if %APPDATA% configuration was chosen, then it is saved in %APPDATA%\Notepad ++\plugins\Config\PythonScript\scripts

    Installation mode can be verified by checking ? menu and debug-info.

    Cheers
    Claudia



  • Weird…so I uninstalled and then reinstalled Python and now it works. I guess the first python install was buggy or something.

    Thanks again for your help. And for your work around. It appears to be doing exactly what I was hopping for. Thanks!



  • Good to see that you’ve got it sorted out.

    Cheers
    Claudia


Log in to reply