Comments don't work?



  • Comment doesn’t work? I’ve been using Notepad++ for years. I use it mostly to edit Javascript. For the past few updates the Alt-Q shortcut and commenting lines has intermittently not worked. Now, with the latest version it’s not working at all. What’s up? I can’t even use the pull down menu to comment lines. Help!?!



  • @Paul-Vorn

    just for information, not EVERY language is supporting the block comment although java script supports it.

    Can you describe in more detail what exactly happens when bringing up the context menu.
    Doesn’t it work at all? Are parts disabled? For any language?
    Can you post the debug-info?
    Maybe, temporarily and only if used, rename %APPDATA%\notepad++ directory and start npp again.

    Cheers
    Claudia



  • Are you sure you have the correct shortcuts? You said Alt-Q, but my Edit > Comment/Uncomment submenu shows Ctrl-Q on my installation, not Alt-Q. And the Settings > Shortcut Mapper > Main menu entries agree.

    That screenshot was from NPP 7.2.2. But when I noticed you claimed “latest version”, I finally download 7.3.1 (which still hasn’t auto-updated for me), and confirmed the same.

    Looking at ? > Debug Info > Copy debug info into clipboard:

    Notepad++ v7.3.1   (32-bit)
    Build time : Jan 17 2017 - 00:21:10
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : ComparePlugin.dll dbgpPlugin.dll mimeTools.dll NppConverter.dll NppExec.dll NppExport.dll NppFTP.dll NppTextFX.dll PluginManager.dll PythonScript.dll 
    

    Once 7.3.1 was installed I tried: File > New, Language > J > JavaScript, typed var a=1;, then tried out the Ctrl-Q toggling, Ctrl-K multiple times to add multiple levels of single-line comment, Ctrl-Shift-K multiple times to clear them, and Ctrl-Shift-Q to use a block comment, and they all worked exactly as expected. (As did going to the Edit > Comment/Uncomment, and selecting each of the five entries.) I then changed to a different lanugage (Perl), which uses different comments, and it still did what I expected.

    Please

    • Confirm whether the shortcuts you are typing match the shortcuts listed in the menu and shortcut mapper
    • Confirm whether using the menu version of the comment commands do what you expect, or not
    • Confirm which version of NPP and plugins you have by looking at the Debug Info.

    If you are able to get it work, great, glad to help. If not, please make similar screenshots to what I’ve done, post them on a sharing site like imgur.com, and embed the images using the notation, and explain why you think the behavior is still wrong.

    ![](http://i.imgur.com/FzoYBAO.png)


  • So I have not seen much of a need for these “comment” commands:

    For a single line, is it really necessary to invoke this command? Perhaps for the C style /* and */ on a single line it is of some use, but do people really use that these days instead of // ? Instead of invoking the command, just put the // © or # (Python) or “whatever” on MANUALLY YOURSELF. :-)

    For a selected block, in the language I use (Python), invoking the Comment command puts a # at the start of the non-whitespace text on every line…well, OK, but if I’m doing it myself I would probably put a three ’ or " chars above the first line and below the last line of my desired block. Worse, though, for the # on every line approach done by “Block Comment” is that the “Block Uncomment” does nothing!

    Am I missing the value here? Can someone explain it to me?



  • Thanks for the replies, and yes, I meant “CTRL - Q” as a shortcut for comment / uncomment.

    I’m writing code for Unity3D in Javascript. Been using Notepad++ for about 8 years for this. When I highlight a block of code, I press “CTRL” and “Q” to comment or un-comment that block of code. Sometimes it works, but most of the time it doesn’t. I also tried using the top pull down menu to comment / un-comment the code. That doesn’t work. I tried selecting only a single line of code. That doesn’t work. I tried closing Notepad++ and then relaunching it. That didn’t fix it. I checked the Short Cut mapper, and yes, “CTRL - Q” is there.

    I only started seeing this issue late last year when I updated Notepad++. Earlier today I updated again hoping the update would fix it only to find it’s even worse. This is driving me nutz!



  • Unfortunately, it’s hard to debug your problem for you, since we cannot replicate your problem.

    Maybe it’s one of your plugins. If you’d give us your ? > Debug Info, it lists the plugins you have installed, and maybe a user here would recognize one with an instability.

    If you try running notepad++ -noPlugin, NPP will load with no plugins, and if that makes it reliable, then probably one of your plugins is interfering. You could then enable one plugin at a time by renaming all the .dll in your installation’s notepad++\plugins subdirectory – if you rename all but one to .xdllx, then only the one will be enabled; if you go thru having only one .dll at a time, you can find which plugin is causing the instability.



  • I completely un-installed Notepad++ and installed a fresh new copy. So far it seems to be working. The new install is the 64 bit version, the old install was 32 bits.



  • I might know what was causing the problem. I have been using a custom language definition for UnityScript (a version of Javascript) that was created by the Unity3D community 6 or 7 years ago. When I did the clean install, I removed all my old settings, including that custom language. I’ve been using this updated / clean version for several hours and so far no issues. I can’t think of any other reason why I would have problems while no one else seems to.



  • If you’re interested in further debug (and I won’t be offended if you aren’t), you could try just installing that one plugin, and see if it really is the culprit. If you’re not interested, I’m at least glad it seems to be working for you. Enjoy.



  • Unfortunately, I spoke too soon. After not running into any issues after the fresh install yesterday, today when I started it back up I can’t use the CTRL-Q toggle to comment / un-comment. Same issue as before. :( Here’s the contents of the debug window:

    Notepad++ v7.3.1 (64-bit)
    Build time : Jan 17 2017 - 00:28:43
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : mimeTools.dll NppConverter.dll



  • I’ve just installed Notepad++ version 6.0 to see if it works any better than the newer versions. As I posted at the beginning of this thread, I’ve been using Notepad++ without issues for years and only started seeing this issue when I updated last year.



  • I believe it has something to do with auto-reloaded files. What I mean by this is, when you open notepad++ then open a file, the commenting feature works fine. But if you keep that file open and close the notepad++ program then relaunch it, the file will be automatically open, and that is when the commenting does not work. But, if you re-open the file, it will work again.

    So basically, files that are opened on launch of the notepad++ application have some issue with commenting using the shortcut.



  • @Finley-Dabinett

    Tested it - I do not have that behavior.
    Must be something else.

    Cheers
    Claudia



  • @Alan-Kilborn

    So I have not seen much of a need for these “comment” commands:

    To be honest - I use ctrl-k (and shift+ctrl+k) exclusively.
    If you are at the position where you can put in a hash ( to stay with the python example) then
    yes, of course, it would be quicker, but I’m almost never at that position.

    Am I missing the value here?

    No, it’s just not implemented - but as said, I don’t care I just have to remember two shortcuts,
    well, not true, three shortcuts (I use toggle comment often also). Single line un-/comment and
    toggle line comment. They work for blocks as well. ;-)

    Cheers
    Claudia



  • @Claudia-Frank

    Your statements make a lot of sense. I think I understand now. I have been using the ‘toggle’ shortcut key since I saw your reply and I LIKE IT. I think I was wanting the “block” version of the command to work, but since the toggle works for single lines or blocks I can just ignore (not use) the block version. Many thanks!



  • @Finley-Dabinett I agree. That is the behavior I am having too. In addition, I changed my mapping for Single Line Comment to another key combination and now my CTRL+K puts a VT in a black box on the page. So there is probably a conflict somewhere even though the mapper says there isn’t any conflicts.



  • No, there is no shortcut conflict. If Ctrl+K is assigned to nothing, it will go back to it’s extremely ancient mapping, which is VT (char 11, 0x0B). Just like Ctrl+J is LF, Ctrl+M is CR, Ctrl+H is BS, and Ctrl+I is TAB.

    (Ctrl+M, Ctrl+H and Ctrl+I all behave just like their ENTER, BACKSPACE, and TAB key equivalents in something like cmd.exe)


Log in to reply