Find no longer Finds anything



  • What happened to find and replace and how do I fix it? I am not a ‘programmer’. I work in web design and frequently use this to remove the infernal <wbr> google inserts when a client sends an embed code (thereby breaking it). Or I did, until recently. Now I can even have it highlighted and it still says its not there.

    I’m forced to resort to transferring the code to my personal mac, opening in Text Wrangler, which has NO problem finding and replacing the gunk. But that is my personal computer and Text Wrangler doesn’t come for PC, I’ve always just used this. Until now, Notepad ++ worked great.

    Is there some reason this incredibly useful find and replace has blown to bits? I’m asking it to do something that should be as simple as ABC here.

    Running Version 7.2.2 and here is the debug stuff.
    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll



  • @Terri-Paxton

    Must be something specific with your installation or usage.
    Could you make a screenshot and upload it. E.g imgur (no registration needed)
    It should show the find dialog reporting the can’t find text message
    together with the text with should be searched.

    Cheers
    Claudia



  • This question is very similar to https://notepad-plus-plus.org/community/topic/13235/search-and-replace-not-working-properly where I wrote the following:

    Occasionally I leave the “In selection” tick box on the replace window ticked, then I get very confused about why a replace does not do what I want. Unticking the “In selection” box and shouting at my mouse for clicking the wrong things lets the replacement work OK.



  • maybe you have Whole Word Only selected in the find dialog



  • :O I think the Whole Word Selected might’ve been it. I find it baffling however and am eyeing the updates suspiciously. I can believe I might accidentally check it on one computer but two? Hopefully, now I can be rid of the curse of wbr code (since Google obviously cares not that every web designer sent embed code via gmail is snarling at them).



  • After NPP stopped finding things I fixed it by downloading the PythonScript_1.0.8.0.msi and choosing “repair” during the installation. Search worked after the repair.

    http://npppythonscript.sourceforge.net/download.shtml



  • Now that we are on it, the “whole word” option is not that practical anyway, eg, it considers a whole word that which is surrounded by spaces. If another character is found next to it, such as (), [], or {}, it is not a “while word” anymore for Npp.



  • @Andrés-Zsögön

    “whole word” IS practical.

    A “whole word” is not strictly defined as “that which is surrounded by spaces”.

    If any of (, ), [, ], {, } is next to what looks like a word, it IS still found when doing a search with “whole word” option enabled, for example, all 12 of the following lines will be found when searched for “abc”:

    abc(
    abc)
    abc[
    abc]
    abc{
    abc}
    (abc
    )abc
    [abc
    ]abc
    {abc
    }abc
    

    But…perhaps I am misunderstanding what is meant by some of your statements…

    A pretty good discussion of what makes up a “word” and how the search engine deals with it was done by @guy038 here: https://notepad-plus-plus.org/community/topic/13004/bugs-in-normal-search-for-v7-2-2-on-windows-7



  • @Scott-Sumner

    I’m afraid it doesn’t. Kindly search for $abc using the Entire Word option with these:

    bla $abc(
    bla $abc)
    bla $abc[
    bla $abc{
    bla {$abc} 404_NOT_FOUND
    bla ($abc 404_NOT_FOUND
    bla )$abc 404_NOT_FOUND
    bla [$abc 404_NOT_FOUND
    bla ]$abc 404_NOT_FOUND

    As you can see, anything with a (, ), [, ], {, } before it won’t be found by Notepad++ 7.3.3 for Windows (X86).

    This makes the Entire Word option so untrustworthy that I can never use it, not with PHP at least.



  • @Andrés-Zsögön

    Well, that case is discussed by @guy038 in the earlier posting I referenced; following the logic presented there indicates that your example will indeed not be matched.

    However, there is a way to get your desired behavior. In Settings (menu) -> Preferences -> Delimiter, change the “Word character list” as shown here: http://imgur.com/a/FhKc1

    Textually, change the radio button so that “Add your character…” is selected, and add the $ to the text box below it.



  • @Scott-Sumner

    Hey that worked perfectly, thanks. The name of the options is not very serious… a gray label with a warning instead of the explanation between parentheses would be more adequate. Is there some place where I can make suggestions for the GUI, to make it more professional and less… amateur? Thanks.





  • I was having this issue and it seems i checked ‘match whole word only’. un-checking option fixed it.


Log in to reply