How to force N++ to open files only in UTF-8?



    • I have a file with the following code: print "Hello World".
    • In Encoding section, Encode in UTF-8 is chosen.
    • I close the file, and open it again: nothing has been changed. Perfect.
    • I add some Unicode character, so the code now is: print "Hello World 😀".
    • I close the file, and open it again; I see: print "Hello World рџЂ".
    • In Encoding section, Encode in ANSI is chosen.
    • Once I forget to change it back to Encode in UTF-8, and start typing something, all Unicode characters are lost.

    Any changes to Settings -> Preferences -> New Document -> Encoding as well as to // MISC. -> Autodetect character encoding change nothing for me.

    Is there any way to force Notepad++ 7.3.2 to open all files in UTF-8?



  • Simplest solution is to encode UTF-8 with BOM.


Log in to reply