Run Commands Issue



  • I’ve been using Notepad ++ for years now and this is the first time I actually need help with.

    Now i do a lot of css/html editing in Notepad++ and I’m always needing to refresh the page on the browsers to check what I did.
    Run on the tool bar a lot and I test my work on all the browsers.

    The issue i’m having is I added GoogleChromePortable.exe some time ago and i just started to use it because the browser I was using was Comodo Dragon and it was lacking a lot of stuff. Now the computer i’m using is a shared computer and Google Chrome Browser is not mine to use but only for code testing. I now use GoogleChromePortable.exe as my main browser.

    So now the issue I found:
    When I had Chrome Portable open and I clicked Run/Launch in Chrome, It kicked out Chrome Portable and launched Google Chrome but did not display my site or anything from Notepad++ and stayed on the (New Tab Page)

    So I decided to close out of both Chrome versions and clicked: Run/Launch in Chrome it did nothing. Never even loaded the browser.
    So i thought ok. Lets reboot Notepad ++ and try again. Nope no go. Fine. Reboot the computer. Nope no go. Well now. Fine update Notepad ++ to the latest. Go try again: Run/Launch in Chrome and I get this:

    The system cannot find the file specified.
    An attempt was made ti execute the below command.
    Command: chrome
    Arguments: “Location”
    Error Code: 2
    Image of the error
    http://files.enjin.com/106810/help/2017-03-01_23-01-03.png

    Well that’s busted. Ok so I decided lets click Run/Modify Shortcut/Delete Command and I found nothing to add GoogleChromePortable.exe
    If i can add that to the run and Opera i would be happy but there is no option to add them.

    Any ideas. This make it more of a chore without the use of run working correctly.



  • @Chris-Hawryluk

    I think your question is really only in the last 2 paragraphs. Everything else is why you are asking the question. :)
    So concentrating on those last 2 paragraphs…

    What I do to add something to the Run menu of commands is:

    • Select the Run (menu) and choose “Run…”

    • I specify the program I want to run (along with any arguments to said program) in “The Program to Run” text/dropdown box

    • I press the Run button to test it and make sure it is working correctly

    • If not working correctly, I go back in via Run (menu) -> Run… and adjust until it is working correctly (the previous text of commands persists)

    • Now that it is working, I invoke Run (menu) -> Run… one more time (again my working command text is still present in the text/dropdown box), then I press the Save… button, name it what I want to appear in the Run menu, and optionally map a shortcut key combination to it

    So…I don’t use GoogleChromePortable or Opera but I don’t know why the above sequence wouldn’t work for either of them…but I’m sensing that you have yet to try something along those lines to get it added to the Run menu.

    Also note that once you’ve finished adding a command to the Run menu, you can tweak it by editing the appropriate line in the shortcuts.xml file.



  • (Select the Run (menu) and choose “Run…”) Done…
    (I specify the program I want to run in “The Program to Run” text/dropdown box) Done…
    (I press the Run button to test it and make sure it is working correctly) opens the browser but my .html page wont show.

    What are you talking about (the previous text of commands persists) and (along with any arguments to said program)

    I want to get what i make in Notepad popup in the browser from the run menu. It’s not doing that and it’s just loading the browser instead of showing the code like: Firefox, Safari and IE does.
    I would really like another browser of choice.



  • @Chris-Hawryluk

    Well, the model (in shortcuts.xml) for Chrome is:

    chrome "$(FULL_CURRENT_PATH)"

    so I would suggest something very similar.

    In this case, "$(FULL_CURRENT_PATH)" would be the “arguments to said program

    There is some small amount of additional information on this topic here:
    http://docs.notepad-plus-plus.org/index.php/Defining_User_Commands



  • Nothing works.
    I can’t even do this.

    <Command name=“Launch in Google Chrome” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe “$(FULL_CURRENT_PATH)”</Command>
    <Command name=“Chrome Portable” Ctrl=“yes” Alt=“no” Shift=“yes” Key=“90”>"C:\Users\UserName\Desktop\Others\All Data\GoogleChromePortable\GoogleChromePortable.exe “$(FULL_CURRENT_PATH)”</Command>

    I click on run and select one of those two and it does nothing.
    If I do this:
    <Command name=“Launch in Google Chrome” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe "</Command>
    <Command name=“Chrome Portable” Ctrl=“yes” Alt=“no” Shift=“yes” Key=“90”>"C:\Users\UserName\Desktop\Others\All Data\GoogleChromePortable\GoogleChromePortable.exe "</Command>

    It opens the browsers and wont show the code. What’s the deal with Notepad ++



  • @Chris-Hawryluk said:

    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe “$(FULL_CURRENT_PATH)”
    What’s the deal with Notepad++

    No “deal”. Computers are detail-oriented. Your double-quotes are imbalanced on the ones that don’t work.



  • Still not working. Try for yourself.



  • @Chris-Hawryluk

    Try it yourself.

    Well, I did try it, before posting what I posted. With the imbalanced quotes, as you said it does nothing (which is sort of bad…some sort of error message might be better…). Once I balanced the quotes out, running the command opened my current editor file in Chrome. Not clear what is going wrong for you with the information given…



  • With or without Quotes I get this.
    http://files.enjin.com/106810/help/2017-03-02_14-06-35.png
    This is getting to be really frustrating to the point I might need to start looking for Alternative editors.
    That’s using this line.
    <Command name=“Chrome” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe “$(FULL_CURRENT_PATH)”</Command>



  • @Chris-Hawryluk

    Ah, okay, I see it now (that .png file makes it really obvious)…your double quote characters are not all the same (see the “a” with the “hat” on it where double quotes should be?). Suggest you make them all like the one before the C in C:\Program Files...…use copy and paste on that character…



  • Still no go. Just copy the hole “Command name” that works for you and i’ll try it. It makes it difficult to guess your steps.



  • @Chris-Hawryluk

    Okay–that’s a reasonable approach at this stage:

    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" "$(FULL_CURRENT_PATH)"

    Of course I’m not positive what copy and paste of that could do to the double-quotes. :-)



  • Both Chrome and Chrome Portable now work showing the code.

    <Command name=“Chrome” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” “$(FULL_CURRENT_PATH)”</Command>
    <Command name=“Chrome Portable” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>“C:\Users\Pauline\Desktop\Others\All Data\GoogleChromePortable\GoogleChromePortable.exe” “$(FULL_CURRENT_PATH)”</Command>

    Thank you for your time. It works great again. Now i can also add Opera to the run. :) Thanks. You made my day!



  • I have the same issue do we have video to see as an example because i am unable to understand it.
    Really really appreciate if you could show in steps please



  • First: Don’t hijack other threads. It won’t help you get an answer here any faster, and it is considered exceedingly rude (and thus would likely influence many potential responders to not give you an answer).

    Second: the contributors to this forum are not paid support, and are in no way obligated to get you your “pizza in 30 minutes or less”. We are fellow users of Notepad++ who volunteer our own time to help other users. It is quite possible for a question to take minutes, hours, or even a day or more to get a response, depending on the topic, how busy people are, how polite you were, etc.

    Third: If you’ve “stopped working” as you claim in the hijacked thread, you’ve made a poor choice. If you were editing your source code using plane-jane notepad.exe (or any other text editor without all the awesome features of Notepad++), you wouldn’t have an auto-launch feature. But you’d have this nice File > Open menu (or equivalent) from Chrome, Firefox, Internet Explorer, Edge, or any other browser I’ve ever seen, which would allow you manually open up your local webpage with only a couple more clicks that running it from Notepad++'s Run > Launch in Chrome would do for you. And then use the browser’s refresh button to reload after you make a change and hit SAVE in Notepad++.

    Fourth: this thread already pretty-well describes what you need to do to get it to work in Notepad++. I don’t see how a video would help.

    However, in a spirit of education, I will summarize the steps for you:

    • Edit shortcuts.xml: it will either be in %AppData%\Notepad++ or in your program’s install or portable directory (same folder as notepad++.exe)

    • place the lines that DestructiveBurn listed in your shortcuts.xml, except use ASCII quotes, not unicode smart-quotes.

      <Command name="Chrome" Ctrl="no" Alt="no" Shift="no" Key="0">"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" "$(FULL_CURRENT_PATH)"</Command>
      <Command name="Chrome Portable" Ctrl="no" Alt="no" Shift="no" Key="0">"C:\Users\Pauline\Desktop\Others\All Data\GoogleChromePortable\GoogleChromePortable.exe" "$(FULL_CURRENT_PATH)"</Command>
      
      • Those rows replace the existing “Launch in Chrome” shortcut

      • The specific paths given ("C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" or "C:\Users\Pauline\Desktop\Others\All Data\GoogleChromePortable\GoogleChromePortable.exe") need to be updated to the appropriate path to chrome.exe on your system.

      • If you are only using a standard installation of Chrome, not a portable edition, you don’t need the “Chrome Portable” row

    • Save shortcuts.xml

    • Exit Notepad++

      • the edited shortcuts.xml will not take effect unless you exit and reload
    • Reload Notepad++



  • Thank you.


Log in to reply