Unable to associate filetypes with new NP++ 64-bit version



  • I downloaded and installed the new NP++ 64-bit version on Windows 7, replacing the 32-bit version I’ve been using for quite awhile. I noticed that all my file associations had been deleted and the icons had reverted to the generic icon. When I tried to re-associate the files using the Properties window, NP++ does not appear in the recommended programs and when I browse to it and select it, it is ignored and does not get set. I’ve also tried associating the files through the NP++ Settings/Preferences/File Association window but that doesn’t work because I not logged in with Administrator privileges.

    What’s changed here as I had to issues doing this with the old version?



  • I have the same problem with the file associations in the latest (7.3.3) 64-bit version. I reinstalled 32-bit version (7.3.3) and was able to change the file associations through the standard Windows properties menu (not through NP++ Preferences).



  • Does it work when using the default program applet?

    If this doesn’t work either it might be that your registry key settings has been changed/corrupted. I can’t really remember which key this was but if you search
    the web for registry and default programs you should find something.

    Cheers
    Claudia



  • Same issue. I can apply the file association a dozen times, but if I close the program and reopen, they all revert back to non-associated.

    If I run the program in Admin Mode, it seems to work, and I imagine this has something to do with writing the settings needed to remember the associations into the /Program Files/Notepad++ folder, since it’s in a protected folder (anything in Program Files and Program Files (x86) does it, I believe.

    I have had a small measure of success going to each file type and opening the submenu (right click) and reassigning the default program. However, this doesn’t address Notepad++ issue in not being able to record it’s own file extensions.



  • Hello

    The way to solve this problem is:

    • uninstall 64 bit version in “Program Files”, and keep optionnaly your settings
    • download and run CCleaner Free edition. go to Registry, Scan for Issues and Fix them…
    • install again np++ 64bit

    Now Windows associations are possible !



  • Uninstall and clear Registry did not work for me.

    There is another way to fix the problem:

    • Go to “C:\Program Files\Notepad++”
    • Right click “notepad++.exe” and “Run as administrator”
    • Then you can freely make change of “File Association”

    Notice that, if you run notepad++ (or associal files) as normal, you will see nothing in “File Association”. But don’t worry, file association still work for you.

    Every time you want to change “File Association”, remember to run notepad++ “as administrator” again.


Log in to reply