SCI_WORDLEFT and SCI_WORDRIGHT treats sentences as words in New File?



  • When working in a regular ol’ saved file, Ctrl+Left and Ctrl+Right skip past words and symbols as it should. In a new, unsaved file, however, the keys skip to the beginning or end of the current sentence (as context requires), as though spaces were part of “words”.

    Is there a setting I need to modify in order to gain the default action for skipping words in new files?



  • @Ron-Poulton
    I don’t have the reported behavior using npp 7.3.2 at the moment.

    Could you provide more details like which lexer (language menu) is in use, your debug-info
    and whether you use themes or not?

    Cheers
    Claudia



  • I’m using NPP 7.3.3. Lexer is “Normal Text”, I’m not actively using themes, and debug-info reports:

    Notepad++ v7.3.3 (32-bit)
    Build time : Mar 8 2017 - 03:37:37
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (32-bit)
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll



  • Ron, I just noticed a similar problem today, possibly tied to recently upgrading to Notepad++ v7.3.3, 32-bit program running on Win7 SP1 64-bit. Ctrl+Left and Ctrl+Right skipped almost whole sentences, occasionally terminating spaces but not terminating punctuation. Double-clicking on a word highlighted the same block of text–i.e. pretty much the whole sentence, much more than a single word.

    Some research showed only this thread referencing the problem, & poking around in my settings showed nothing out of the ordinary. I wondered if I’d copied & pasted weird text with special characters, but editing the text didn’t help. Even moving around & selecting text in NPP’s change.log had the same issue.

    I uninstalled Notepad++ & reinstalled & it’s fine now. During uninstall, it asked to wipe out my user settings & I said yes, in case something got corrupted in there; I’m not sure that was necessary but I knew it’d be easy enough to redo settings I changed. Hopefully this fixes it for you too.

    tl;dr uninstall & reinstall Notepad++



  • While working in the Normal Text file, after I switched the lexer to PHP, the CTRL+Arrow keys skipped words as they should. How do I get this functionality in the Normal Text lexer? I’d like to avoid having to reinstall if possible. I don’t mind changing a setting here and there.



  • I had the same problem.
    I was running v7.3.3 (64 bit). I uninstalled it and installed v7.3.2 (64 bit). It works fine now. :)


Log in to reply