Search results won't highlight hits



  • I used to see the hits highlighted, but no longer. This problems occurs in all languages, even .txt files. I’ve spent an hour working with the settings, under Search Results and elsewhere, running as Adminstrator, but nothing works. No boxes are check in global overrides (except bold, and I only tried that recently).

    In general it’s very difficult to get the styling of elements that I want. What would be great is if one could right click on an element and see where its style is set.



  • @Harry-Binswanger

    What do you mean by

    I used to see the hits highlighted, but no longer.

    do you refer to settings-preferences-highlighting?

    In general it’s very difficult to get the styling of elements that I want. What would be great is if one could right click on an element and see where its style is set.

    I guess this isn’t easy to solve as only the lexer of a language knows what has been colored and
    most important why.

    Cheers
    Claudia



  • It used to be that if I had the text “Now is the time for all good men” and searched for “good” not only would the cursor land on the space after “good” but “good” would be highlighted (yellow background in my case). Now the color remains as it was, which makes it a bit harder to find when I have a lot of text onscreen.

    What is “the lexer” of a language?



  • @Harry-Binswanger

    looks like your smart highlighting isn’t enabled.

    What is “the lexer” of a language?

    A lexer is the software part which is responsible
    for the coloring/styling of the text but each language,
    like python, c, c++, perl, java, html etc…
    do have its own lexer, so it is nearly impossible to have this
    right click functionality you mentioned as this means that every
    lexer needs to implement this feature.

    Cheers
    Claudia



  • Claudia,
    Thanks for the reply. I found Smart Highlighting under MISC. in the Preferences, but it is enabled. It has to be something about the color scheme I have, but lots of experimentation hasn’t turned it up. I also once mucked with Stylers.XML which could be the problem. But there are several Stylers.XML and lots of data in each. I assume it’s in the Default stanza, at the bottom, because the problem comes even when searching plain .TXT files.
    Any other ideas? The inability to find the cursor is really annoying.



  • @Harry-Binswanger

    It has to be something about the color scheme

    ok, if you are not using the default theme than I would go back to the default one
    to see if the problem has gone. If this is the case, than compare the entries
    of the stylers.xml file with the theme xml you use and you are correct, the highlighting is defined under the GlobalStyles.

    I assume the easiest would be to download a zipped version of npp, unpack it and replace the theme you are using with the latest version.

    If the default theme has also the issue, than I would think about renaming the
    %APPDATA\notepad++% directory, of course only if it exists and is used by your npp installation.
    APPDATA directory is used, if debug-info, which is available under ?-menu
    (I hope your version has this already) states Local Conf mode:OFF.

    Cheers
    Claudia



    1. The smart highlighting was already enabled.

    2. If I fresh-install, how do I re-instate all the customization of styling I already have? I guess I can figure that out for myself.

    3. What I don’t understand is that there is a specific place to set this: Search Results/ Hit word, but nothing I do there has any effect. I have put in special effects and font size changes and colors, none of it makes any difference.



  • @Harry-Binswanger

    The smart highlighting was already enabled.

    Sorry, don’t understand this answer? Did you try default theme? Is the issue still happening?

    If I fresh-install, how do I re-instate all the customization of styling I already have? I guess I can figure that out for myself.

    Do not do an install, unzip it to a directory of your choice and run npp from that directory.

    What I don’t understand is that there is a specific place to set this: Search Results/ Hit word, but nothing I do there has any effect. I have put in special effects and font size changes and colors, none of it makes any difference.

    If a config file gets corrupted it is likely that not all parameters do get loaded/assigned as expected. Btw. which version are you running?

    Cheers
    Claudia



  • Problem solved: the way I was searching was to use an AutoHotkey macro loaded onto ctrl-L (a keystroke I automatized using back in the days of Wordstar!). For various reasons, the macro made the cursor move right one character after the “hit.” That killed the smart highlighting.

    So I took out the cursor-right, leaving just F3, and now I’ve got my highlighting back!

    Thank you for your help!



  • @Harry-Binswanger

    glad you solved it.

    Cheers
    Claudia


Log in to reply