langs.xml missing when starting notepad++ from batch script



  • Hi,
    I’m using a version control system (serena dimension) that allows me to configure user defined tools via context menu -> cmd script.
    I want to use notepad++ to e.g. view sources, so i’ve setup a cmd script that pulls a certain version of a file form vcs to a local temp directory and fires up npp with this file.

    The script looks like (simplified):
    <get the file from vcs to c:/tmp/tmpfile.txt>
    <path to npp>/npp c:/tmp/tmpfile.txt

    The script is launched via a context menu of the vcs.
    When i run the script, i get the “load langs.xml failed” and “load styles.xml failed”.
    I already played around with cd’ing into the <user>/appdata before launching npp and so on but without success.

    Any idea what i’m missing?
    Thanks in advance,
    br johann



  • @johann-woeckinger

    No idea. Have you tried adding <path to npp> to your PATH environment variable? I don’t have any reason to believe it will help, but it is something to try.



  • After some pausing & thinking i digged into the problem again and i think i was hit by https://github.com/notepad-plus-plus/notepad-plus-plus/issues/3088. After reinstalling with (or better “without” the dont-use-APPDATA-option) it works like a charm.
    Sorry for bothering you,
    br johann


Log in to reply