tabs selected when doubleclicking on words



  • as the title says… And when I make a search with “whole word only”, it doesn’t return the words folloying a tab.
    Apparently, Tabs are considered as word characters and not as spaces.
    I’ve got this problem for a while. So, is it due to a bug in a new version, or to a bad involontary setting from my part ?

    Thank you for your help, since this behaviour is very annoying !



  • I’m not sure if this is the cause, but I just discovered the feature to do this the other day:
    You can add a character to the list of characters included in words. On the Settings menu, open Preferences, then go to the Delimiter section. If you have characters in the Add your character as part of word, then either remove the tab character from that list, or just click the Use default Word character list as it is.



  • Thank you for the tip, but, this is not the cause : it was allready on the default normal option.



  • @Denis-Peter

    can you post the debug-info which is available under ?-menu
    Did you try to run npp without plugins active? (rename plugin directory)
    Could you make a screenshot of this issue while having show all characters enabled?

    Cheers
    Claudia



  • Thank you, but… The problem has mysteriously disapeared !

    However, here are the debugg infos (in case it could explain something to somebody) :
    Notepad++ v7.3.3 (32-bit)
    Build time : Mar 8 2017 - 03:37:37
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll



  • Same problem. But not all the same.

    The first case after the latest updates Notepad (rollback 7.3.3 Jun 08 2017). After double-clicking on a word, there is selected all lines, including spaces, quotes, brackets. But not leading tabs!

    In the second case, now. After reading this topic I go to “Preferences -> Delimiter”. There is a default. I put in “Add your caracters” some text and save it. Nothing will change. And I went and set back to the default settings “use default”.

    And now (see joxi.ru/K823xxxcZN4LAO.png) there are only spaces in doulclick selection.
    But that’s not good. And this is so weird and mystery.

    May be it happened due to the difference in the 7.4.1 and the 7.3.2 settings format?



  • @Hotmel

    if this is still an open issue, would you mind starting npp without plugins?
    Either by using the -noPlugin commandline switch or by temporarily renaming the plugin directory.
    If this doesn’t solve the issue, can you post the debug-info?

    Cheers
    Claudia



  • @Claudia-Frank

    Oh. After a few days the problem disappeared. Exactly.

    It seems that the plugins haven’t been updated. Nothing plugins was switched off. Npp ver 7.3.3 remained as before.

    Mystic.
    Perhaps the problem disappeared after reseting “Preferences -> Delimiter” and restart Npp.


Log in to reply