Notepad++ plain text tends to wiggle, and ignore end parenthesis )



  • I’m running version 7.4.2 as an improved TEXT -NOTEPAD to take notes during meetings, etc., allowing me to open and create several different TEXT files simultaneously. This version (and almost all in recent memory) have a practical problem. When I move my cursor back into the text to edit (mis-spelled words, etc), the text often wiggles back and forth - making corrections difficult. And the end parenthesis ) sometimes will NOT move to the next spot, but I must use a cursor or such to get the cursor out of the ) enclosure. My desktop & laptop all run 100% current Win10 with plenty of RAM & CPU power. Is it because I favor 14 point font COMIC SANS MS font (easy to see at a distance)? Is there a bug in the program?



  • @Frank-Cox73

    may I ask how you configured the font exactly and what lexer (can be seen in statusbar, left corner, first field), if any, is active?
    Can you post the debug-info (can be found under ? menu)?

    Cheers
    Claudia



  • @Frank-Cox73

    Not 100% sure what you mean by “wiggle”, but it may have to do with the fact that Comic Sans is not a mono-spaced font; each character has its own individual width, so, in general, there will be no visually identifiable columns.

    Try some mono-spaced font (Consolas, Courier, Courier New, FixedSys, Lucida Console, etc.) and see if that solves your problem.



  • This post is deleted!


  • @Claudia-Frank
    Hi Claudia
    Thanks for getting back to me.

    1. I selected the Comic Sans font by choosing Notepad++ options
      Settings
      Style Configurator
      Font Style
      Font Size
      Enable Global Font.
    2. Lexer … even with your description, I haven’t a clue what or where that is.
    3. Debug info:
      Notepad++ v7.4.2 (32-bit)
      Build time : Jun 18 2017 - 23:34:19
      Path : C:\Program Files (x86)\Notepad++\notepad++.exe
      Admin mode : OFF
      Local Conf mode : OFF
      OS : Windows 10 (64-bit)
      Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll SpellChecker.dll
      And please see my response to Jim Dailey’s questions (below)
      Thanks!
      Frank

    Answer: to Jim Dailey …
    Thanks, Jim
    I think you are correct. Comic Sans is not mono-spaced, and now that I shifted to
    plan vanilla ARIAL the slight wiggle when I edit / correct a line has stopped.

    And: I figured out that NOTEPAD++ AUTOMATICALLY DISPLAYS the
    ending / right side parenthesis when you start by typing in a
    starting / left size parenthesis. This is a phantom character, and you don’t really have an
    ending / right side parenthesis there. You have to physically TYPE IN the
    ending / right side parenthesis over the ‘phantom’ one to make it stick…

    Overall: I’m done. Thanks to all.
    I’ll stick with ARIAL and type in the ‘real’ ) character over the phantom ) character.



  • @Frank-Cox73

    Hi Frank,
    nice to see that you got sorted it out but this phantom thing confuses me.
    If you don’t mind, could it be that you’re talking about the auto-insert function?
    (Settings menu)

    If you uncheck those, there should be gone but just to make clear,
    the automatically inserted ending chars are real, for example if you type
    a starting parenthesis, as you said, the ending parenthesis will be added.
    Now if you type another letter (not the ending parenthesis) you will see it will stay
    and if you save the file you will see it will be saved as well.

    Cheers
    Claudia



  • Bingo - you’re right!

    I had Settings / Preferences / Auto-Completion / Auto-Insert ( )
    “ON” and the phantom ( ) appeared - causing me Auto - Confusion.
    I’ve unchecked the boxes and now I’m happy!

    Frank
    Simple is good.


Log in to reply