FTP always disconnect itself or doesn't connect



  • Hi ! I can’t connect to my project anymore and I don’t know why. Everything was fine for years (I’m not kidding) and today everything seems broken. So I have a website running on which I try to do some updates as usual, but today I can’t connect via the FTP window, from time to time I can for few minutes and then everything goes to hell again… I’m a rookie and I tried to restart my computer, my internet box and I re-installed the last version of Notepad++, nothing worked so far. I clearly can’t work with Notepad doing this !

    And now it’s working again !!! I didn’t do anything ! I still need help because it’ll not last forever.

    Thanks for your time
    (Sorry about my English)



  • Does anyone has a clue about what’s going on to me ? I still can’t upload my changes so I basically work in the dark, Notepad++ is still not relatable and it fails to upload 99% of the time. I didn’t change a single thing, I use Notepad++ as I always do. I click on “connect”, then the name of my project and nothing happens. Either it says “disconnected” either I do a Ctrl+S and it fails to upload. I could give you the error log I got but it’s worthless, it’s just “load XXXX…XXXX failed”.
    Do I need to remove the cache from Notepad++ ? It says “at your own risk”, I’m not sure if it’s a good idea.
    If any of you could help it would be cool.



    • Which version of Notepad++ (? > Debug Info > Copy Info to Keyboard)
    • I assume by FTP you mean “NppFTP” plugin. If not, stop here and clarify. Otherwise, continue.
    • Which version of NppFTP? (Plugins > NppFTP > About NppFTP)
    • When you turn on NppFTP’s “Show Messages Window” (the icon to the right of the gear icon), does it show an error message (usually highlighted red)? If so, what error message?


  • Notepad++ v7.4.2 (32-bit)
    Build time : Jun 18 2017 - 23:34:19
    Path : C:\Program Files (x86)\Notepad++récent\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll

    Yes I meant NppFTP.

    Apparently, the version of the NppFTP is
    Zlib version : 1.2.11
    Libssh version : 0.7.5
    OpenSSL version : 1.0.2k 26 janvier 2017
    NppFTP version : 0.27.0 Unicode

    No, the gear is still grey.
    It worked two times tonight (23:37 here) and I still have no idea why it sometimes works and sometimes doesn’t.



  • Sorry, not the gear itself. It stays gray. But if you toggle the “Show messages window”, which is the rectangle to the right of the gear:

    … if you toggle that, you will get a messages window below, something like:

    This is where we need you to report the error listed, if there is one. You can copy/paste from that window. In my example, the error is:

    [SFTP] Connection failed : kex error : no match for method kex algos: server [diffie-hellman-group-exchange-sha256], client [curve25519-sha256@libssh.org,ecdh-sha2-nistp256,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1]
    Unable to connect
    

    My guess is that you’ll be seeing an error similar to mine. For that specific host, I used to be able to connect, but cannot any more, though I don’t know when that error started for me. I just went back thru the NppFTP Releases on GitHub: tried v0.27.0, v0.26.9, v0.26.8, v0.26.7, v0.26.5 from July 2015, and v0.26.1 from Feb 2015 (the earliest github release): none of those versions would connect. So I don’t think it’s actually a problem with a change on the Notepad++/NppFTP side of things. Per this github issue, the NppFTP developer believes it’s a recent configuration change on the server side. (It may still be something the NppFTP author could fix by configuring openssl differently in the plugin, but I don’t know. If I have time, I may do some more research, and ask some questions on the OpenSSL issues board, to see whether OpenSSL 1.0.2k is missing that feature, or whether it’s something that needs to be enabled by the NppFTP/client.)

    As a workaround for mine, instead of using NppFTP to remote-edit the files in Notepad++, I use FileZilla (3.26.2, 64bit): I set Edit > Settings > Filetype Editing ☑ Use custom editor: "C:\Program Files (x86)\Notepad++\notepad++.exe" (yes, since there are spaces, it needs the quotes), ☑ Always use default editor, ☑ Watch locally edited files and prompt to upload modifications. Then, when I right-click and Edit the remote file in FileZilla, it opens up Notepad++ with that file. When I save in Notepad++, Filezilla says “File has changed” and asks if I want to upload back to the server (optionally, also if I want to delete the temporary file – which I only check if I’m done editing and have closed it in Notepad++)

    But I don’t know if your issue is the same as mine or not: knowing the actual error that NppFTP shows is the only way to confirm or further debug your issue.



  • Wow I was not expecting this :
    421 2900 users (the maximum) are already logged in, sorry
    Unable to connect
    Disconnected

    … I don’t know what to think about this…



  • You might want to contact support for that server, and see if it needs a reboot or something. :-)


Log in to reply