Recent File History Never Shows



  • Recent file history has not been showing after installing last few new updates. Use to always be on left. Looking through Preferences hasn’t helped as I’ve tried various changes. Is there a new setting(s) I am missing to get the list of last 20 files (increased from 15) that were opened?

    Also, recently opened files do not open/show after starting NotePad++. That use to work also so you didn’t have to look for recently opened files you were working on. Am I missing a setting for this too? It now opens with new document only and NO recent file history.

    All backup file paths have been set if this may have an effect on the problems. I hope they are set correctly.



  • @Ron-Payne said:

    Recent file history has not been showing…Use to always be on left.

    Perhaps you mean the Doc Switcher ? It isn’t a “recent file history”, it’s a list of all currently open files and it can be wherever you put it, but maybe its default location is on the left (that’s what made me think that you might be talking about that–mine is on the left currently).

    If Doc Switcher is what you are looking for, enable it at Settings (menu) -> Preferences… -> General (box on left) -> Document List Panel (box) -> Show checkbox. I’m not at all sure why it is named differently in the Preferences than what it shows on its window (“Document List Panel” versus “Doc Switcher”)!

    recently opened files do not open/show after starting NotePad++

    I think the setting you are looking for here is in Settings (menu) -> Preferences… -> Backup (box on left) -> Remember current session for next launch checkbox.

    If this (or ANY other posting on the Notepad++ Community site) is useful, don’t reply with a “thanks”, simply up-vote ( click the ^ in the ^ 0 v area on the right ).


Log in to reply