Undo & Redo: Strange Behavior in NPP



  • I thought I was in Word. I wanted to insert the n-dash. I pressed Ctrl± (minus on the numeric pad). Strangely, Npp changed the font in the file (in all opened files, actually). Holy smokes. I pressed Ctrl-Z to undo; Npp just deleted my last sentence (before pressing Ctrl±). I pressed Redo on toolbar. Npp jumped a few lines up in the current file.

    I repeated Undo/Redo a few more times trying to revert to the state before I tried that “cursed” sentence! The font remained as undesirable. Closed and restarted Npp. The look of Npp was what I did not want. I tried to change the font in Style Configurator to no avail. Npp stubbornly refuses (like its author :)) to accept my font!!!

    How can I go back to my configuration? Thank you for any help (no regex or python, please!)

    But, hey, it’s free beer, right?



  • As in most other programs using control and minus changes the zoom…which is exactly what happened with Notepad++. The font didn’t change at all. Use View > Zoom > Restore Default Zoom



  • @dail
    Hey, thank you! I realized later it was the behavior of zooming in a browser. I pressed Ctrl+Numeric+ and the font became readable again. There are so many, many features in this editor… and NO help facility at all! Npp needs a BIG manual. Any Good Samaritan here? We can’t count on the author… that’s a guarantee!



  • @go2to

    You can always take it upon yourself to become the Good Samaratin and write one. ;)


Log in to reply