Auto spell check not available



  • Yes, I downloaded Notepad ++ about 2 weeks ago. I double checked to make sure i had the updated version and i do. Auto spell is not installed and ive been looking online everywhere and even on ya’s website and i cant find anything to install it. It says to go under “plugins” but it does not list there. Only things that list is, “Converter” and “MME Tools”. Do i need to uninstall and reinstall this to help the issue or what do i need to do?



  • @David-Wimmer

    Maybe you need the Plugin Manager plugin, which has been removed from Notepad++ release 7.5, although this release is not yet two weeks old. In your Plugins menu see if you have an entry for “Plugin Manager”. If you don’t, see this link for getting one: https://notepad-plus-plus.org/community/topic/14325/plugin-manager/3 . After that perhaps you will be able to find the spell-check plugin you are seeking.

    I suspect we will see a bunch more (ugh!) of these types of postings here in the future. It really seems to be backward thinking to remove the Plugin Manager from the distribution the way it was done. It seems like the smarter way would have been to wait until a replacement is available.



  • would “plugin manager” be the same as “plugins” tab?



  • @David-Wimmer

    Nope. You will have a top-level “Plugins” tab. Plugin Manager is a plugin itself. This is what it should look like:

    Imgur

    If you don’t have this, you need to get it from the link I mentioned earlier.



  • So this is what i downloaded and i added it to my plugin folder as it described on the V2.0. I downloaded the V.1.4.9 and put it in my plugin folder. I restarted my computer and then i saw the plugin manager. I clicked “show plugin manager” and it gave me a list of everything i wanted to download. I saw the “dspellcheck” and “autosave”. I click those (2) and hit “install”. After it downloads it ask me to restart “note pad ++” and i do. When i do that, this message pops up. “A file needed by the plugin manager (gpoup.exe) is not present under the updater directory. You should updateor reinstall the PLugin Manager plugin to fix this problem. Note pad ++ will not restart”



  • @David-Wimmer

    In the zip file you downloaded that had the Plugin Manager in it, there was also a file named grup.exe. Put that file in the “updater” folder under the Notepad++ main folder (“updater” is at the same “depth” as the “plugins” folder). After that, retry installing “dspellcheck” and “autosave”–it should go okay…fingers crossed for you.

    If you really read the text of the message you got, it pretty much tells you to do what I just said. :-D



  • Haha wow, cant believe i missed that! Thank ya so much for this help! If anyone has this issue, please refer to this as it was VERY easy. I also used this one to download and it was pretty much self explanatory. https://github.com/bruderstein/nppPluginManager/releases


Log in to reply