Paste into column stopped working



  • I’m running np++ 32-bit, v7.5.1, on Windows 10 Professional 64-bit. To try to resolve the problem I’ve uninstalled & reinstalled it (then I had to manually install plugin manager). Downloaded the .exe from https://notepad-plus-plus.org/download/v7.5.1.html

    Coincidentally (or maybe not?) I’ve just applied the latest Patch Tuesday update from Microsoft.

    Pasting into a column, which I’ve used for years in np++ with no problems, has stopped working as it used to.

    Steps to reproduce:
    Open new tab.
    Type in these lines (terminated with an extra blank line BTW)
    a
    b

    1
    2

    Then select the lines containing 1 and 2 & copy to the clipboard in the usual way.
    Click mouse at end of line starting with ‘a’.
    Ctrl+Alt+Shift + mouse click at end of line starting with ‘b’.
    You now have the familiar ‘long cursor’ at the end of the 2 lines, as expected. Make sure this isn’t a selection.
    Ctrl+V to paste the clipboard text in.
    What I used to get is a file that looked like

    a1
    b2

    1
    2

    What I get now is a file that looks like

    a1
    2
    b1
    2

    1
    2

    I’ve made sure that ‘word wrap’ is turned off, as I’ve read this can have an effect.

    Thanks in anticipation for any advice.



  • Additional info: if the column that was originally selected & copied to the clipboard wasn’t in the last column (i.e. immediately preceding any newline characters) then the paste works as expected.

    i.e. if the source was
    c1
    d2

    and you selected the column containing ‘c’ and ‘d’ & copied it to the clipboard, then pasting it after ‘a’ and ‘b’ works as expected.

    So is the original ‘copy’ picking up the newline characters as well as the selected characters? That would explain the weird behaviour of pasting the column in the scenario described in the OP.

    Thanks in advance for any advice.



  • @alanrew

    column insert and append works fine in np++ 7.5.1 with your given example …
    … but not with your given instructions to reproduce.

    you have to press and hold the alt key while marking the column part containing 1 and 2
    (otherwise you will copy the line feed after 1 which will result in a multi line insert, repeating the clipboard and including the line feed between 1 and 2, like you got in your example)

    then select edit > copy from the tool bar
    then press and hold the alt key while marking the column part after a down to after b
    then select edit > paste from the tool bar

    you will now end up with your desired result:
    a1
    b2



  • @Meta-Chuh

    Thanks very much for your help - I’d completely forgotten about the need to use the ALT key while copying the ‘1 and 2’ column.

    Thank goodness this isn’t a bug: I rely on np++ for my job (which is why I donate :-)).

    Kind Regards,

    Alan


Log in to reply