Text File does not display in Notepad++ (Many versions)



  • I have a Text file that just does not display in 32bit Notepad++ 7.5.1 - I have tried previous 32-bit versions (back to 6) and none of them correctly display the file contents. The file displays ok with Windows XP Notepad.



  • EXTRA INFO – It seems something to do with the default Character Set Encoding used when the file is opened.
    When I select Encoding/Character Sets/Western European/ISO 8859-1 the file contents are displayed correctly.

    1. Can I change the default character set when an existing file is opened?
    2. I have tried to record & replay a macro to select the character set but this seems not to work.

    Any help/pointers would be gratefully received.



  • @Steve-Dyson

    1. Can I change the default character set when an existing file is opened?

    unfortunately not at the moment, this has not been fixed yet.

    even if you go to preferences > misc > and disable autodetect character encoding, it will open an existing utf8 file as utf8 and not to what you’ve set as your default


Log in to reply