Changing comment character in assembly

  • I changed the comment line character for assembly in the langs.xml file from ; to // since the architecture I’m working with (ARMv8 with gcc compiler) uses // to denote comments. After changing this and restarting notepad++ it still detects ; for comment lines. What can I do to force notepad++ to detect // as the start of a comment line when working in assembly?

  • Adding more details:

    I made other changes at the same time such as adding to the list for register keywords and that was detected, however another change that I made was not detected (changing it to recognize the extension s. I made these changes on both my home computer and my laptop with the same result. I don’t use cloud at all either.

  • More recent update:

    I got the extension working, it was just also listed as an extension for R. comment line still not working.

  • More info:

    using ctrl+k inserts // as expected it’s just the syntax highlighting that doesn’t work.

  • 6 months later, same problem still exists…

Log in to reply