Macro problems

  • Very glad to find an editor with macro capability.
    I maintain an eBay purchase history file.
    First I copy new purchase info as a text file.
    This must be cleaned up and modified before
    being added to my complete current file.
    This has been a hideously tedious process involving up to 37
    line replacements plus possible additional group modifications.

    However, I’ve encountered a few problems with macros.
    Had to redo my macros many times.
    Really wish you would add a macro edit0r option.
    By the way, reviewed all the plugins. No help.

    Most lines to be replaced include a line return.
    I have discovered the Replace “Regular expression”
    must be closed and redone for each such string.
    Fortunately, most unwanted lines require complete removal.
    For these I repeat the “Normal” option as many times as possible.
    Then I use the Line Operations - Remove Empty Lines option.
    This works, but a bit of a nuisance.
    Is the need to redo the “Regular expression”
    each time a bug? Or am I doing something wrong?

    Also, the “Regular expression” won’t work
    with a line return as the 1st character.
    And one line combination simply won’t work.
    This is:

    • US $0.00

    Only way to fix this is by replacing the first line with @
    Then a “Regular expression” of the modified lines works.

    Some line groups may be present only rarely.
    Sadly, the search function doesn’t have a “on not found” option.
    So, for 3 specific line groups, I had to make additional
    macros that must be run as many times as needed.
    And, one must check for each initial search string before running the macro.
    If the macro is run when no longer required,
    the commands after the initial search are still executed.
    Buggers the file.

    With these I found I must use the “Begin/End Select” option
    to block a line for deletion or cut for insertion elsewhere.
    Typical cursor blocking doesn’t work in a macro.
    Also, in one case, I have to do a search
    “Backward direction” to position for line insertion.
    Discovered I have to immediately return to the search
    just to turn off the “Backward direction” choice.
    Would be nice if this one choice would
    automatically clear with each new search iteration.

    I hope my comments may be of some value.
    Otherwise, thank you for this fantastic text editor.

  • @Jayson-Cohen

    If you are comfortable with some programming you might want to check out

    This community will help, I’m sure.

Log in to reply