cr/lf suddenly appears



  • So Notebook++ is a fantastic text editor,
    So I am typing away and suddenly all the lines below are ending with cr/lf. So I undo and undo and this feature does not ondo. I have no clue what function keys I have activated. I have no clue as to which pull down screen describes and controls this condition. Please help.



  • @Stuart-Langley

    Probably the quickest way to undo is to press the toolbar button that looks like a backwards P (also called a “paragraph marker”). That button is likely in the “pressed” (active) state in the toolbar, and all you need to do is deactivate it.



  • @Scott-Sumner
    I tried the backwards P and it added more CLRF but would not remove those already in place. Are there control keys that do the same thing?
    I used cntl-A to highlite entire doc and tried backward P but it would not impact the CLRF already added.
    I was tying and probably hit cntl something. I can copy and replace the file, but was figuring there has to be a way to reverse this beast. :)



  • @Stuart-Langley
    View --> Show Symbol, click to untick the ones you don’t want.



  • @Stuart-Langley

    if @decoderman 's advice doesn’t help, maybe provide a screenshot (hints on doing that here , near the “lady pic”) to help clarify what you’re talking about.



  • @Scott-Sumner
    “The lady” is Dolores del Río, a Mexican actress if google is right.



  • @decoderman

    Yes, I made that posting on her birthday, I think…and she was the Google Doodle of the day (I needed a quick image to illustrate my example of how to embed an image in a post). :-D



  • @Scott-Sumner @decoderman
    none of these view ->show symbols were marked. Checking end of line, added CRLF to the rest of the document, but unclicking only removed those added by the checkmark.
    At the point of the text I was adding; the image shows the transition, I was typing and dragged a pinky over ctrl and hit a key while adding text… or something…
    - the image was created at imgur. It did not render here for me…



  • @Stuart-Langley

    It doesn’t have to render here…a imgur link would be fine…but I don’t see one in your previous posts?

    Accidental Ctrl + other-key presses can result in apparently odd characters inserted into your document (they’re really not odd if you understand what they are) but this shouldn’t cause changes to large sections of your document. Here’s an example of what you might see if you press Ctrl+e followed by Ctrl+r (with the default keymapping):

    Imgur

    Note that you’ll see this even if none of the three View (menu) -> Show Symbol options are ticked, as indicated above.



  • @decoderman @Scott-Sumner
    my url did not fit through submittal and editing did not work.
    imgur.com/xJDeA7T - the image was created at imgur. It did not render here for me… I have now left out the code, so a human can find the image. I now have to wait 1200 seconds to add this. :)



  • @Stuart-Langley

    Hmm…about the only thing I can tell (beyond what has already been discussed) is that you have mixed line ending types in your document – almost always a bad thing. Windows line endings are CRLF. See the one line where the line ends in LF without CR in front? This is a Linux type line ending. I upvoted 2 of your posts so you should no longer have to wait before posting.



  • Thanks for the upvotes, @Scott Sumner. Thanks for all the help too. Thanks @decoerman for the help.
    All the added line returns and carriage returns started with inadvertent keystrokes right at this point. And no screens opened up. The action was instantaneous. Like oh, crap… fast. :0
    I can recreate the entire document in a new file and then rename to the original deleted file name. I just thought I was a dope and did not understand an easy edit. Notepad++ is a tremendous and powerful tool. That is why I use it. Of course, things happen.



  • So there was a remarkably easy solution to my predicament.
    Opened a new file. crtl-A -> crtl X - paste into new file. Cut and paste back into original. I could have probably even cut this back to cut and paste.
    Again thanks for all the help with this issue.



  • @Stuart-Langley
    Next time try Edit / EOL Conversion to Unix and back to Windows EOL. Maybe the mix up will be gone then.
    But copy/paste seems a good workaround for now.



  • The CR/LF marking just happened to me too. It appeared on all the lines below the line I was working on, yes on the working one, and not on any above. I feel like I may have made an inadvertent keyboard combination because I was adding some punctuation at the time. I’ve tried the suggestions and the behavior was just as noted. Copy/Paste success.

    This is not the first time this has happened. It is rare, but it happens every month or two. The copy/paste workaround is good enough for now.

    You’re going to love this: Okay, current working line and all below developed a CR/LF. All of the lines below dropped the first character of the line. Current working and above maintained the first character of each line.

    When I pasted the complete copied text into a new document it was complete. Initial characters appeard, CRLF did not.

    Next, sometimes I’ll put in blank lines for readablilty. The preceding line will not display CRLF. When I have multiple blank lines, the last line with a character will not display CRLF and none of the blank lines will either, until the last blank line above the next line of text.



  • @Reed-Scarce

    I think you are probably experiencing a Notepad++ bug and may be suffering data loss!?

    Check out @dail 's posting in this thread .





  • @Scott Sumner, THANKS.
    I’m getting used to posting to this board and the constraints.
    My last post was to a screen shot, one that wasn’t necessary after I viewed your informative post. I’d already lined it up and just pressed submit after the mandatory 20 minutes. Then I read your post.
    RE: Your Post - I’m betting you’re right. Over time I’ve let many open tabs accumulate. I have Notepad++ in Startup and, you get the rest.
    Ultimately, after making sure there was no corruption, I hit ctrl-S and the CRLF/Initial-Char issue resolved its self.
    So thanks!


Log in to reply