Cannot Change Recent Files History Count



  • Under Settings > Preferences > Recent Files History the “Max. number of entries” box will not save any change.
    OS - Win7 Pro
    I set it to three different numbers and each time it remains at ‘15’.
    I have uninstalled and reinstalled.
    I wish to set it to ‘0’.
    How to solve this issue?



  • @Dave-Manning

    as it is working for me I have to assume that either your installation is somehow corrupt
    or you don’t have proper rights to do it.

    Can you post your debug-info? (available under ? menu)

    Cheers
    Claudia



  • Uninstalled 7.5.1 x64 because no plugin manager.
    Installed 7.3.3 for plugin manager and textfx.
    Checked permissions and have full control as admin and as user.
    Debug info:

    ===
    Notepad++ v7.3.3 (32-bit)
    Build time : Mar 8 2017 - 03:37:37
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : HTMLTag_unicode.dll mimeTools.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll

    Thanks for your assistance.



  • @Dave-Manning

    can you give it a try to

    • stop npp
    • rename %APPDATA%\notepad++ directory
    • start npp

    Cheers
    Claudia



  • @ Claudia Frank
    I assume you meant %APPDATA%\Roaming\notepad++ directory or %APPDATA%\Local\notepad++ directory - as there is no %APPDATA%\notepad++ directory
    Renaming both solved nothing.
    I have completely uninstalled Notepad++ - including deleting all directories in %APPDATA%\Roaming, %APPDATA%\Local and Program Files X86 - three times, with absolutely no ability to change the Recent Files History Max Number.
    And the most recent update changed nothing either.

    The small pop-up window with the “max files” comes up
    I can change the number - both by typing in and using count arrows - but when I close the window, the number remains at 10.

    Is there another avenue to try, such as a registry key?



  • @Dave-Manning

    Sorry, was pretty confident that it is %APPDATA%\notepad++,
    but could be that my memory plays a trick on me.
    It’s been a while since I’ve used windows.

    As far as I know, no, npp doesn’t save this in the registry instead
    it uses different config files. The one in question is config.xml.

    And the line is

    <History nbMaxFile="10" inSubMenu="no" customLength="-1">
    

    From your debug-info output it should be the one under %APPDATA% as the
    Local Conf mode is OFF but just to be sure, check the one under C:\Program Files (x86)\Notepad++ as well.

    Cheers
    Claudia