How to get it to read .ss files as html?



  • I tried deleting ss extention from scheme in the langs.model file and adding ss to HTML in Style Configurator, but it still reads .ss files as scheme files.



  • Hello @nika-rudolf and All,

    Not very difficult, indeed ! But, first, we must identify where the Configuration files, of your N++ configuration, are ! So, choose, in N++, the menu option > ? > Debug info… :

    • If the Local Conf mode line is set to ON, you have a local N++ configuration => You probably got Notepad++ via a .zip or .7z archive and your configration files should be in the N++ installation folder, along with the executable file notepad++.exe

    • If the Local Conf mode line is set to OFF, you probably got Notepad++ with the installer and your configuration files should be :

      • In the %AppData%\Roaming\Notepad++ folder, if your system is a W7, W8 or W10 machine

      • In the %AppData%\Notepad++ folder, if your system is a XP, or Vista machine


    IMPORTANT : We’re going to modify two configuration files : langs.xml and stylers.xml. So :

    • In Notepad++, close, first, all your opened .ss files. Then, choose the menu option File > Empty Recent Files List, in order to delete any reference to the .ss files, in the session.xml configuration file !

    • Now, close any instance of N++ and BACKUP your active files langs.xml and stylers.xml as, for instance, langs.bak and stylers.bak ( One never knows !! )

    • To edit the langs.xml and stylers.xml files, you must NOT use Notepad++ and use, exclusively, MS Notepad or MS wordpad or any other text editor !!


    Then :

    • Open the langs.xml file and change the line :
        <Language name="scheme" ext="scm smd ss" commentLine=";">
    

    into :

        <Language name="scheme" ext="scm smd" commentLine=";">
    

    Save the changes and exit the langs.xml file. Now, open the stylers.xml file and change the line :

        <LexerType name="html" desc="HTML" ext="">
    

    into :

        <LexerType name="html" desc="HTML" ext="ss">
    

    Save the changes and exit the stylers.xml file


    Finally, open Notepad++ and load any .ss file => It should be opened, automatically, with the HTML language :-D

    Best Regards,

    guy038



  • Thank you so much, I did it and it works fine!


Log in to reply