spelling verification in comments ?



  • Hello, what happen ? I’m coding in C, Notepad++ language = French, and suddenly (since few days) almost words in my comments are underligned in red, exactly like in Word, althouth they are absolutely correct ! Who is responsible, the last update of Notepad++ or the one of Windows 10? An idea anybody?



  • @Jean-Yves-Breton

    One of the changes in 7.5.2 was “Add DSpellCheck plugin into distribution” so maybe what you are seeing is simply a matter of the spell-checker now being there and active?



  • Thank you Scott, indeed I just discovered this new (?) button “Spell Check Document Automatically” before looking again at the forum: that is the reason. One click on it and the red underlinig disappear. But we have to note that this automatic checking doesn’t take care of the language indicated in the preferences: it doesn’t know French.
    It’s not a problem. Thank you again.



  • @Jean-Yves-Breton

    Well, I would think you would just set the language the DSpellCheck plugin is using, via its Change Current Language menu option…which has nothing to do with Notepad++'s language (aka Localization) setting.



  • You’re right, i confused the two elements. Now I downloaded the french dictionary for DSpellCheck, choosed the French option in its menu option, and now everything works fine. Thank you very much!


Log in to reply