Cant select 64-bit version as default text edit program in win 7?



  • If I use the x86 exe it works, but I uninstalled and got he x64 since my PC is 64 bit. But now when I use the x64 exe it doesn’t show up in the list of programs when I select it. Whats the issue?



  • @Daniel-Buitron

    Sorry, but it is not clear for me where you did what.
    Did you use default programs from control panel or explorer context menu or something else?

    Cheers
    Claudia



  • Having the same problem here.

    Had x32 installed for years.
    Uninstalled x32 version
    Installed x64 version

    Windows now opens things like xml files in normal notepad
    When I choose “Open With”, notepad++ is not one of the default options
    And even when I search for a program and choose the x64 notepad++.exe file… it just ignores it as it I hit cancel.

    Need some sort of registry fix when switching from 32 to 64 I guess.



  • Ok I found it

    1. use regedit to goto:
      [HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command]
    2. Change this
      “C:\Program Files (x86)\Notepad++\notepad++.exe” “%1”
      to this:
      “C:\Program Files\Notepad++\notepad++.exe” “%1”

    Then Open With should work now and let you choose Notepad++



  • Actually there appears to be about 6 or 7 locations in regedit if you search for:
    C:\Program Files (x86)\Notepad++

    and edit each place to remove the " (x86)" part



  • This fixed it for me.

    It’s been bugging me for years. Ten minutes with regedit made notepad++ appear as an option in “Open with->Choose default program”.


Log in to reply