Issue when trying to overwrite a closing brace on notepad++



  • I’m using notepad++, no plugins installed. Whenever I use a character such as (, [, or {, it auto-completes in red. When I reach the end of whatever I’m inputting, I just close it manually so it “overwrites” the auto-completed one.

    HOWEVER, it doesn’t overwrite the closing brace } if I’ve hit ENTER during the code. It just duplicates the closing brace so I’m left with }} at the end of whatever I have, so I have to manually delete one of them. Has anyone else experienced this, and do you have a solution? Thank you.



  • @CodeSteady

    at some point code must make some assumption but from what I understand you don’t need this function at all so
    why not disabling it? Settings->Preferences->Auto Completion uncheck the auto insert checkboxes.

    Cheers
    Claudia



  • It helps immensely when starting a block, and helps keep everything eye-friendly.

    The function works when using the opening and closing braces in a single line. It only bugs out when I press ENTER after creating the opening brace. I also tested it with parentheses and brackets, and the same issue happens only if I press ENTER :/



  • @CodeSteady

    sorry, haven’t check the code, but I assume, as you already found out, the “enter” triggers the closing part to become permanent.
    Maybe worth investigating whether there is language specific plugin which offers the functionality you are looking for.

    Cheers
    Claudia



  • @Claudia Frank
    yea i’m looking into workarounds, with no luck so far. I’m hoping a dev sees this, or I that I can contact one, to see what the issue is. Perhaps it’s just a bug



  • @CodeSteady said:

    do you have a solution?

    Instead of pressing } just press right-arrow (or End) to move beyond the auto-inserted closing brace? :-)


Log in to reply