Notepad++ 7.5.4 Clickable links no longer work (again)



  • I opened a new text file, and entered
    http://www.yahoo.com
    then <ENTER>.
    The text gets underlined correctly, and hovering over it changes the cursor to the usual pointed finger.
    But when I tried clicking on the underlined link, it does not open in any of my browsers (Chrome, Edge or IE 11). I tried clicking, double clicking, and CTRL clicking. No difference.
    This used to work in my previous version of notepad++;
    The clickable links settings in Settings -> MISC is set to Enabled (default).
    I tried, following various Google posts, to disable this, then exit np++, then start it again, set to enable again, then restart np++ again. The link in the text file remains underlined, and the cursor changes to pointed finger, but still the link is not opened.

    I’m running Windows 10, and my Internet and browsers are all working correctly.
    Clicking the links in Notepad++ -> ? -> About Notepad++ correctly opens the links in my default browser (Chrome).
    So there is no problem with my Internet, browsers, and even NP++'s ability to open a URL in the default browser; just it’s ability to open clickable links from a text document.



  • I would just like to say… WoW, I never knew these even worked. I’ve been using 7.5.3 for weeks now, and they didn’t work there and I thought that was intended behavior even though I would try, from habit, to click them as in other apps. I eagerly await a response! :-) Sorry this isn’t an answer or solution. :-/



  • Tried both x86 and x64 - both are working for me but only with double-click.

    What reports debug->info? (available under ?-menu)

    Cheers
    Claudia



  • Debug info report is below:

    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll mimeTools.dll NppColumnSort.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll Tidy2.dll XMLTools.dll

    But I think I have a better idea about the problem now.
    The problem is that for at least this version of np++, double tapping on the touch keypad does not work in the editor window - ie… does not have any effect in any document in any editor window.
    Other operations on the touch keypad work:

    • Single tap positions the cursor at the tapped point
    • Tap and drag works to highlight a range of text
      etc.
      Also, clicking and double clicking on the touch pad BUTTONs work normally.
      In particular, double clicking using the touch pad BUTTONs correctly opens the URL in the default browser window.
      Only double tapping on the touch pad doesn’t work.
    • Double tapping on a word to select/highlight it doesn’t work
    • Double tapping on an underlined URL does not open it in a browser.

    Both of these used to work in previous versions of np++, although my version may have been a few versions back.

    I’ll be posting a separate topic on this.


Log in to reply