Notepad++ 7.5.4 - Double tapping on touchpad does not work in any document in editor window in Windows 10



  • Double tapping on the touch keypad does not have any effect in any document in any editor window.
    Other operations on the touch keypad work:

    • Single tap positions the cursor at the tapped point in the document
    • Tap and drag works to highlight a range of text in the document
      etc.
      Also, clicking and double clicking on the touch pad BUTTONs work normally.
      In particular, double clicking using the touch pad BUTTONs correctly opens the URL in the default browser window.
      Only double tapping on the touch pad doesn’t work.
    • Double tapping on a word to select/highlight it doesn’t work (not highlighted)
    • Double tapping on an underlined URL does not open it in a browser.

    Both of these used to work in previous versions of np++, although my version may have been a few versions back.

    Debug Info is below:

    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll mimeTools.dll NppColumnSort.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll Tidy2.dll XMLTools.dll



  • @Devarajan-Swami

    i just tested np++ 7.5.4 x86 on w10pro x64 (1709 build 16299.192) with a touchpad and can not confirm this issue.
    double tapping on a word highlights the word as expected
    double tapping on a link opens the link in the default browser as expected

    what happens if you double click a word in the default windows notepad or word ?
    does it mark the whole word as it should ?



  • Thanks, Meta.
    Double tapping works fine in other Windows applications:

    • Double tapping or double clicking on Windows Notepad highlights words and URL links, as expected.
    • Double tapping or double clicking a word on Microsoft Word highlights the word.
    • Double tapping or double clicking a URL link on Microsoft Word opens the link in the default browser, as expected.
    • Behavior in NetBeans 8.2 also works the same as Word, as expected.

    But the incorrect double tapping behavior remains on my install of Notepad++ 7.5.4, unfortunately.



  • Double-tap on my laptop’s touchpad works fine for me in 7.5.4 as well (32bit for my experiment)

    Have you tried running without plugins (notepad++.exe -noPlugin, or rename the plugins\ subdirs in the notepad++ executable directory and/or the %AppData%\Notepad++\ directory)? Maybe one of your plugins is somehow interfering.



  • Peter, those are good suggestions, and I tried all three of them, somehow it is still not working.
    Double clicking works, double tapping does not.
    Arrrggggh :-)



  • After a bit of googling, I found http://windowdetective.sourceforge.net, which appears to be able to watch what messages go in and out. I make no guarantees about the safety of this app, though my virus detector said nothing. Use at your own risk.

    After installing and running (and looking at their documentation), here’s a simplified procedure:

    1. Click (and drag) on Pick Window, and drag it into your NPP editing window.
    2. In the Window Detective hierarcy pane (on the left), it will highlight a “Scintilla” row
    3. RightClick on the highlighted “Scintilla” and select “Messages”
    4. Click on the red STOP button to stop intercepting messages temporarily; the button will change to a green START button
    5. Click on the eraser to the right of the START button, which will clear the screen
    6. Click on the filter icon
      1. Exclude All
      2. Type WM_LBUTTON in the FIND box
      3. check ☑ WM_LBUTTONDBLCLK
      4. (and possibly ☑ WM_LBUTTONDOWN, ☑ WM_LBUTTONUP, if you want to watch all “left-click” messages)
      5. click OK
    7. Click START button
    8. Using mouse, double-click on something in your NPP window…
      1. You should see a → WM_LBUTTONDBLCLK and ← WM_LBUTTONDBLCLK indicating NPP was sent the DoubleClick, and responded
      2. If you filtered on the DOWN and UP, you’ll likely see other LBUTTON messages, too.
    9. Double-tap on something else in that same window, and you should see another copy of the message
      1. If you see the → WM_LBUTTONDBLCLK and ← WM_LBUTTONDBLCLK, then NPP was sent the DoubleClick.
        1. If there, expand the ← WM_LBUTTONDBLCLK, which should show a return value of 0
      2. If all you see is UP and DOWN, without the DBLCLK, then windows isn’t seeing your DoubleClick to pass on to NPP
    10. Click the STOP button again

    When I ran this procedure, everything worked as I expected.

    As far as I know, from the NPP (and internal scintilla) perspective, it’s getting a WM_LBUTTONDBLCLK message, and it doesn’t know whether it’s from the mouse/click or the touchpad/tap, so I don’t see how separate behavior could arise. But if you aren’t seeing the DBLCLK message when using the touchpad, then maybe something is wrong on the driver side, I think (though that doesn’t explain why it’s working in other apps).

    Also, maybe play with “double-click speed” settings for either your mouse or touchpad, and see if maybe that will help.

    Good luck.



  • I have the exact same problem on my Surface Pro 3 / Win10 !



  • It appears this is a Scintilla bug. Scintilla is a vital component of NP++ and several other text editor-type programs, which are probably all exhibiting this behavior.

    Bug reports:
    https://github.com/notepad-plus-plus/notepad-plus-plus/issues/3895
    https://sourceforge.net/p/scintilla/bugs/1983

    If you, like me, value ‘tap twice’ word selection over ‘tap twice and drag’ multi-select, follow this workaround:

    1. Go into Windows 10 ‘Touchpad settings’
    2. Disable ‘Tap twice and drag to multi-select’

Log in to reply