Cannot open program SciLexer.dll certificate problem



  • Upon launching today I get three messages and Notepad++ won’t start.

    1. Checking certificate of C:\Program Files (x86)\Notepad++\SciLexer.dll : Cannot find the requested object

    2. Authenticode check failed: signature or signing certificate are not recognized

    3. ScintillaEditView::init : SCINTILLA ERROR - Can not load the dynamic library.

    I’ve tried the following and none of them worked and I still cannot open the program:

    1. upgrading to the latest version
    2. uninstalling - reinstalling latest version
    3. rebooting after reinstalling

    How can I fix this problem?



  • Is SciLexer.dll available at C:\Program Files (x86)\Notepad++\SciLexer.dll? Which version of N++ ? 7.5.4 32-bit? On which OS version?



  • Yes the file was in that location. I removed and reinstalled fresh several times so I think I was getting a new copy of the file each time I installed. I was using 32-bit.

    I switched to v7.5 64-bit and I’m able to run the program again. No idea why all of a sudden it just started yelling about that file. Then I downloaded a fresh installers (all 32-bit versions) and it never worked with 32-bit. 64-bit versions all seemed to work. No idea why the 32-bit versions throw such a fit.

    Unfortunately, a couple of my favorite plugins are missing from the 64-bit version. =(



  • Turns out other programs on my machine started failing too.

    This is how I fixed the problem:

    A Windows component that is responsible for verifying digital signatures is no longer functional.
    Re-registering the wintrust.dll may resolve the error. This is however without guarantee and also at your own risk.

    The following command in the command line window (as admin) would have to be executed:

    regsvr32 c:\windows\SysWOW64\wintrust.dll

    … or you copy a working “wintrust.dll” from another machine.

    I ran the command from the command line in Windows as administrator and then I installed 7.5.4 32-bit and it works again.



  • This comment may be off-topic for Np++ here; but, you shouldn’t have had to do that! I suppose, though rare, that some cosmic particle corrupted wintrust.dll but; that’s suspicious behavior… to me! I’d certainly not just settle for fixing that unless you ‘know’ why it was replaced, or corrupt… especially if not missing.

    If it got corrupted then it’s possible some 3rd party app may have corrupted the registry, or ‘something else is going on’ ?!? If you do auto backups of your registry I’d try to do a restore if you have one from a date prior to the issue to see if that fixes the problem. Since it may also ‘fix’?!? (cough) other issues that were the cause. At your discretion of course, as going back a few days, depending on what apps and system changes you’ve done would ‘naturally’ be affected by a restore; however not doing a restore might cause future issues left unresolved, such as a corrupted registry as in registry keys?!?

    At least do a Windows Defender, or other anti-virus scan, and a sfc (systems file check). IOW although the issue affected Np++, as you pointed out, other parts fo the system were also affected (infected?). I would want to rule out the latter!
    (Sorry for the slightly off -topic guys.)


Log in to reply