lag experience of typing.



  • I am using Notepad++ (64 bit) v7.5.4 in Windows 10 v1703 build 15063(64 bit). My issue is backspace response is much slower(during typing) as compare to inbuilt notepad. Please fix this problem.



  • Could you explain a little bit more in detail what you mean please. Time from hitting the backspace key to reaction on the screen. Or holding down the backspace and iterating? Does this depend on the document format? Does it happen with disabled plugins?



  • I am using Notepad++ to save basic words and notes not in english but also in hindi language because inbuilt notepad does not support hindi texts, now my actual issue is after type some words(in case of english texts only) when i “press and hold” backspace button, then responding very slow, no matter that my texts are saved or not in txt format using Notepad++ , and no any additional plugin installed.



  • Hello @gaurav-sahare,

    First, I would open the a command line interpreter instance ( cmd ) Then, in the console window, I would type in MODE CON. After validation with the Enter key, you’ll see the present state of the CON peripheral ( The Win32 console )

    And, for the keyboard device , I would use this command MODE CON RATE=31 DELAY=0, which after validation, forces the repetition speed of keys to its maximum ( 31 ) and the delay between hitting keys and the action keys to its minimum 0

    Whatever your configuration, your keyboard should react quickly. and it’s really interesting, when you hit, for instance, the arrow keys, to navigate in your documents ;-))

    Cheers,

    guy038



  • Yes! you are right. This method really works. Thank you so much sir @guy038 to solve this problem. Now I am no longer facing slow backspace response issue.



  • @guy038

    I would think that going to the Control Panel for the Keyboard works just as well:

    Imgur



  • Hi, @scott-sumner an All,

    Of course, Scott, I know that this setting can be done, from within Windows ! But, as I didn’t know the exact name of the fields, in English, and thinking about people, with lot of windows in their native language, I thought it was easier, for everybody, to open a cmd instance and simply type in the command MODE CON RATE=31 DELAY=0 ;-))

    Best Regards

    guy038



  • @guy038

    I think the most important thing was the diagnosis, which you provided. [I had no idea from the original posting that it was going to end up being a typematic rate problem]. My addition was just a different way of doing it–I think most can adapt what I was saying into their own specific languages, regardless of what the exact text is.


Log in to reply