Notepad++ CS-Script Compilation Error



  • I just installed CS-Script on my notepad++ and when I run any code this error pops up in the output:

    Error: Specified file could not be compiled.
    System.MissingMethodException: Method not found: ‘!!0[] System.Array.Empty()’. at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.TraceCompilerInput(String cmdLine) at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.Compile(CompilerParameters options, String compilerFullPath, String arguments, String& outputFile, Int32& nativeReturnValue) at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.FromFileBatch(CompilerParameters options, String[] fileNames) at Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.CompileAssemblyFromFileBatch(CompilerParameters options, String[] fileNames) at csscript.CSExecutor.CompileAssembly(ICodeCompiler compiler, CompilerParameters compilerParams, String[] filesToCompile) at csscript.CSExecutor.Compile(String scriptFileName) at csscript.CSExecutor.ExecuteImpl()



  • @Julian-Aung

    I’m not using csharp very often but could it be that you haven’t saved the file you
    want to compile beforehand?

    Cheers
    Claudia



  • I have already saved that file.When, I tried to save it again it says "The file is already opened in notepad++."So, I overwrote that file on top of another file and compiled but failed. :(



  • Which version of https://github.com/oleg-shilo/cs-script.npp/releases and which N++ version on which windows version?



  • Notepad: 7.5.4
    CS-Script: 1.7.8.0
    Windows 7 Ultimate Service Pack 1



  • As you are using the current release I think creating an new issue at https://github.com/oleg-shilo/cs-script.npp/issues makes sense.



  • Thanks, I will create a new issue then.



  • P.S: I think this issue occur because of the latest release of both NP++ and CS-Script this didn’t happen in the previous versions of NP++.If I remembered correctly, CS-Script worked just fine with the NP++ plugin manager pre-installed version.


Log in to reply