Notepad++ doesn't show a normal text file



  • Hello,

    I experience an odd problem:
    I want to check a log file that contains pure ascii text, no formatting of any sort. It always worked with notepad++ but now, the screen just stays blank and the file is not shown at all. When something is added to the logfile, notepad++ asks if I want to reload it but also after reloading it, the screen is still blank.
    I can check the log file with gvim, winmerge, wordpad, notepad, … without any problem and I can also check similar log files with notepad++, just not this particular one.
    I’m using version 7.5.4 (32 bit).
    Any ideas what might be causing this?

    Thanks!



  • I uploaded a screenshot showing the properties of the file, the file in gvim and the blank notepad++ including version info.
    Maybe this helps with finding the cause of the problem.



  • @Cell-Test it might be helpfull to:

    1. attach the actual logfile or at least part of the logfile which still gives the same problem;
    2. include Notepad++ debug info (see ? menu)


  • Here is the debug info from notepad++:
    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : AnalysePlugin.dll DSpellCheck.dll HTMLTag_unicode.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll NppTextFX.dll PluginManager.dll SpellChecker.dll XMLTools.dll

    Since I didn’t see how to attach a file here, I uploaded it. You can download it here.

    I copied the contents of the file to a file test2.log in the same directory and notepad++ displays that file as expected while it still just shows a blank screen when I reload test.log from disk. I copied the whole file from the original location to c:\temp\test and this copy is also not shown, so I have no clue what may cause the problem.



  • Notepad++ displays the 22 lines of text and the one blank line of the linked logfile just fine.
    Could you check by running Notepad++ without any plugins? i.e. rename plugins-folder or start Notepad++ with -noplugins command line option.



  • I run notepad++ without any plugins now:
    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : none

    and notepad++ still shows a blank screen with this file while it does show a copy of the file. I added screenshots to “blank screen” and “show”.
    I can work with the copy but I find it quite odd and thought someone might have experienced something like this already. If not, I’ll just ignore it.
    Thanks for your suggestions though.



  • Yes, that’s strange. The last thing I can think off is an encoding mismatch.



  • Hello @cell-test, and All,

    I uploaded your test.log file and I got, as expected, a displayable file, like @MapJE71 did !?

    I just noticed that the Properties window of your file it gives a size of 2,264 Bytes. As for me, the size of the uploaded file is 1,501 bytes, only ! It’s an UTF-8 encoding file. where all characters code are under \x{0080}. So number of bytes = number of characters = 1501

    Remainder :

    • To get the number of characters, of current file, looks at the length : zone, in the middle of the status bar

    • To get the number of bytes, of current file, choose View > Summary… and see the line File length (in byte)

    I created a copy, with the UCS-2 LE BOM encoding ( which is the default Windows Unicode encoding ) and I got a file of 3,004 bytes. This is logical, as, with that encoding, each character is coded with two bytes + the invisible Byte Order Mark, in two bytes, as well => 2 x 1,501 + 2 for BOM = 3,004 bytes !

    Unfortunately, this value is also different from the 2,264 one ! So, like @MapJE71, I’m at a dead end, too ! It could be interesting to open that specific file with an hexadecimal editor, which will give you the exact code point of each character !

    Best Regards,

    guy038


Log in to reply