Right-click, "edit with notepad++" error



  • Whenever I right-click on a file to click the “edit with notepad” item, I get an error box. I have searched the registry and have not found anything useful. The error box can be found here http://www.drteeth.co.uk/notepad++/ as I could not find a way to attach it to this message.

    Similar errors in other programs have been fixed by placing “%1” in the command line WITH the double quotes. It is a placeholder for the file name.

    Cheers

    DrT



  • Strange. That command looks reasonable (other than trying to open a PDF, which is a binary format, not a text file, with a text editor). My open with Notepad++ command is a REG_SZ with C:\Program Files (x86)\Notepad++\notepad++.exe "%1", which looks like what yours probably is, too.

    Doing some googling for “shell execute failed (2) Is this command correct” (ie, the text of your error message) leads to a post in this forum, which indicates notepad++.exe executable has been set to run as administrator, which might be causing the issue, and claims that not running as admin will fix it.

    If you really want it to run as administrator, this superuser.com answer gives a procedure that claims to be able to associate it and still run as admin. In short, delete the old key, and create a new one. One implication (thought it wasn’t explicitly said): the key they deleted possibly had the ++ in its key-name (Edit with Notepad++), whereas the new key-name did not (OpenWithNotepad is what they suggested; for clarity, I would use OpenWithNotepadPP). Then again, it might just be where they put their association.

    Note: after making the changes to the registry, you might need to log out and back in to get the changes to take place.


    btw: to embed the image, you would use ![](http://www.drteeth.co.uk/notepad%2B%2B/edit-with.png), which results in . The little ? in a circle in the upper-right of the forum’s COMPOSE window takes you to a link that explains this.


Log in to reply