KOS in KSP word wraping???



  • Hi every one I’m using the newly found Notepad++ for a in game Scripting add on Mod. The problem is I can use just plan note pad to make these plane text files but in notepad++ when I save my work it all gets squeezed together as in “set warp to 3.if (x + y)=5{do this}.//comment” in stead of.
    set warp to 3.
    if (x=y) + 32{
    do this
    }
    //comment
    This cause a problem in the in game compiler.
    Also I haven’t used the set your language features yet.
    Any help? thank you Rob



  • you have to check what end of line setting is set for your files. you can check by opening a known good file and going to Edit menu - EOL Conversion - and see what OS is grayed out. that is the type you have to save your file as. also check the files encoding in the Encoding menu. it will tell you what document type the file is in. Also check your Settings menu - Preferences to see if the New Document is set for your specific line ending and encoding. i have mine set to windows and use ascii encoding by default but if you need to change the encoding just use the encoding menu to convert to the encoding you need. also if the line ending is unix (LF) when you open the file in a regular windows notepad you will see the text in one line as windows programs look for (CR+LF) as line ending.



  • Thanks Ill try that.


Log in to reply