Slowdown with pasting text



  • Hello,

    I installed Notepad++ a few days ago but what I found was a slowdown in the program after I paste some text in it and then press enter. I just use it for notes, not programming, so I do nothing but type some notes and paste text a lot. What happens is that is doesn’t register the enter key when I press it right after I paste text (doesn’t matter how many/few characters) so the program will not jump to the next line, which is very annoying.

    You can check this by pressing control + v in the program and then as quickly a possible press enter after it and keep doing that. Does anyone else have this issue? It doesn’t happen in other programs I use btw. Thanks in advance for your replies.



  • Have you tried disabling all plugins? Rename C:\Program Files (x86)\Notepad++\plugins to something else and restart N++ and see if the problem still occurs.



  • I just tried it but it didn’t help unfortunately.



  • Anything else I can try?



  • Are you sure you aren’t accidentally hitting Ctrl+Enter?



  • I’m 100% sure that I’m not hitting ctrl+enter.



  • Hello, Peter,

    May be, there isn’t any connection, but, does checking off the wrap feature, ( Menu View - Word Wrap ), stop the issue ?

    As for me, I often noticed that the wrap feature, slow down, drastically, scrolling,while using, repeatedly, the Up and Down arrow keys, especially, on big files !

    Cheers,

    guy038



  • It seems to work for regular text but not for url’s. When saving url’s in notepad++ one by one I get this weird box. I think it might be slowing the program down. I don’t know what it is so I’ll add a screenshot below. Is there any way to disable this?

    screenshot



  • On my machine if I paste a URL and press Control+Enter I get something which looks like your screenshot.

    In my shortcut mapper (off the settings menu) I can see that Control+Enter is set to “Word Completion”.

    My guess is that on your machine that function is tied to Enter.

    If that is the case , in the shortcut mapper, right click on the word Enter and select modify. Change it to something else, or to nothing at all.

    David



  • There is no auto-completion like word completion on in my settings menu.



  • Are you using Session snapshot (Settings -> Preferences -> Backup -> Enable session snapshot)? That could conceivably cause a block when pasting (but not every time, so it’s a long shot).



  • The screenshot shows an auto-complete list of terms. It can be configured in Settings > Auto-Completion


Log in to reply