Using wildcards to filter files in the Open dialog



  • Sometimes I have a folder with a lot of files and I want, for instance, to filter all files containing ‘boat’. In older versions, I could just type ‘boat’ in the file location, hit enter and I would see my files filtered. In the new version it seems this changed, it just closes the dialogue box. Is that a setting?



  • I’ve run into the same problem. In prior versions I could enter something like *foo* in the filename field of the File Open dialog, hit return and see the matching files to select from in the main pane. When I do the same in 7.5.6, it opens all files matching *foo*. I’ve checked the configuration settings and if there is a setting to control this behavior, I’m not seeing it. I also reviewed the change.log and don’t see any mention of this change, so it is possibly inadvertent. In any case, it’s also highly annoying when I enter a wildcard that matches 50 files and they all open.



  • @Robert-van-Geel @Doug-Keys

    goto Settings->Preferences->Default Directory
    and check use new style dialog…

    Cheers
    Claudia



  • @Claudia-Frank

    Questions that lead to this answer seem to have overtaken missing-Plugin-Manager questions as our most-frequent of FAQ. Because the questions are occurring en masse NOW, I would guess that installing 7.5.6 over a previous version un-ticks a previously ticked Use new style save dialog (…) setting? If true, there is (of course) no mention of this in the change log.

    Just a supposition as I don’t ever “install”, and I don’t use 7.5.6 as I don’t like being on the “bleeding edge” of things…so I haven’t noticed this myself. Indeed, if I had, and it bothered me, I would “tick the box” and not give it another thought.



  • @Scott-Sumner

    Hi Scott,

    how are you doing? Hope you are fine.

    I agree, this question pops up quite often lately but I didn’t do any research yet.
    I don’t install npp myself, always using the zips, so can’t say for sure but from my understanding an
    update would not overwrite custom configurations. New installation might be different.

    I remember, when introducing this new style dialog feature we saw also a lot
    of complains that users can’t see the file extensions anymore, so I suspect that when it
    will be reenabled as a default setting the complains would arise again :-)

    Cheers
    Claudia



  • @Claudia-Frank said:

    @Robert-van-Geel @Doug-Keys

    goto Settings->Preferences->Default Directory
    and check use new style dialog…

    Cheers
    Claudia

    Thanks, this resolved the issue. Since this setting also controls the new Unix style path issue, I assume the change to support Unix paths had something do with it. In 7.5.1, the setting is “use new style save dialog” instead of just “use new style dialog”.


Log in to reply