Open with ... does not present Notepad++ as an option



  • Cannot get Notepad++ to associate to any specific file type. From the Preference menu - nada. From Open With … it doesn’t even appear as a possibility (when you search for additional files and select Notepad++ it does nothing) - nada. By far my favorite editor but verging in useless at the moment!



  • Are you using the 32bit or 64bit Notepad++?

    If it’s the 64bit, my guess is that this thread will solve your problem.

    Regarding being “verging on useless”: you do know that most apps, including Notepad++, have this File > Open dialog? Or that most (including Notepad++) have the ability to drag a file from an explorer window into the Notepad++ window, and it will automatically open it? Personally, I have Notepad++ almost always running, so it’s nearly as easy to drag the file as to right-click to open.

    But you are right, having file associations work properly is nice (which is why, back in the XP days, I quickly learned how to manipulate file associations in the registry myself, so that I could fix it when greedy programs assumed you always wanted it to be the default for all the file types it recognized, or when I otherwise wanted to customize things).

    If you aren’t on 64bit Notepad++, or if you are on 64bit but the other thread doesn’t help, please post more details: For example, please go to the ? > Debug Info..., click on copy debug info to clipboard, paste it into an empty Notepad++ tab, Ctrl+A to select all, TAB to indent, Ctrl+C to copy, and then paste it into your reply.


Log in to reply