Windows 10 and default file associations not working



  • Hi,

    I have installed the latest desktop version of Notepad++ 7.5.6 on Windows 10 (edition Pro, version 1709, build 16299.371). Notepad++ installed fine. But setting file associations with “Run as administrator” does not work. Also Notepad++ does not appear in Windows 10 “Set defaults by app” settings section:

    Settings -> Apps -> Default apps > Set defaults by app

    The only workaround I have found is to set each association one by one manually by double clicking on a file with that extension and manually selecting Notepad++ as the default app.

    Is this the only way to do it? Why doesn’t Notepad++ appear in the Windows 10 “Set defaults by app” settings section?

    Thanks for any help!



  • I face a similar problem.

    Windows 7 64bit SP1

    When Installing npp.7.5.6.Installer.exe (32bit) the txt files get associated to Notepad++, or at least I can create the association from the context menu ‘Open with…’ / ‘Choose default program’.

    Wen installing npp.7.5.6.Installer.x64.exe this is not possble: not only the entry for Notepad++ doesn’t appear on the context menu ‘Open with…’ , nor in the dialog opened from ‘Choose default program’,
    but even if I browse to '“c:\Program Files\Notepad++\Notepad++.exe” and press ‘Select’ the association is not created.

    I use WinPatrol, and maybe that is interfering and causing the problem, but this problem still doesn’t appear with the 32 bit version of Notepad++.

    Best Regards,
    Marcello


  • Banned

    This post is deleted!


  • [SOLVED]
    Worked: ‘File Associations’ in Notepad++ [Settings/Preferences/File Association/Notepad] then add .txt to Registered extensions box:

    https://community.spiceworks.com/topic/2170302-is-anyone-else-having-trouble-setting-notepad-to-be-the-default-txt-editor


Log in to reply