Resets to top of document when I change tabs within N++



  • Say I’m working in file A (Storyxyz.txt). I also have file B (lexicon.txt) open. Storyxyz.txt is more than 20 lines long, but that’s not terribly unreasonable. I’m scrolled down to look at lines 20-30. Suddenly, I need to copy a special symbol from lexicon.txt, since part of the file is in a foreign language using æ as a recurring character.

    When I go back to Storyxyz.txt, it is reset to line 1. Every. freaking. time. The section I was focused on is now buried down and I have to go find it again.

    This is getting super obnoxious.

    I’m running a fresh load of Windows (done just five weeks ago) and should have the latest version of N++ on my pc. Version info below for both. There’s literally no reason for it to do this.

    The six files open have 8, 21, 17, 30, 25, and 27 lines respectively. The longest is 2875 characters. Pretty small files. and I can’t be out of RAM.

    PC info:
    Windows 7 64 bit, latest updates, dual core PC with 8GB RAM.
    http://prntscr.com/jmbet4

    N++ info:
    v7.5.6 32-bit
    http://prntscr.com/jmbfre

    What can I do to resolve this bug? Notepad by itself doesn’t work for what I do.



  • @Loren-Fangor

    what you’ve described does not happen to me.
    Could you provide the debug-info (available under menu ?->Debug Info…)
    and a step by step description with an example of the file content of what you are doing?

    Cheers
    Claudia



  • Debug info:
    Notepad++ v7.5.6 (32-bit)
    Build time : Mar 19 2018 - 00:26:59
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll

    PROCESS:
    Step one: Open two files.
    Step two: Scroll down, work on the story, add a new character, yadda yadda. Pause at around line 20.
    Step three: Switch over to the second file, maybe double check some character info.
    Step four: Switch to the original file, and discover it has gone to line one without warning.
    Step five: Scream in agony depending on file length.
    Step six: Reboot laptop with no success.
    Step seven: Uninstall/Reinstall with no success.
    Step eight: Attempt to find alternative program that uses .TXT files and is decent.
    Step nine: Resort to trying to fix N++ because Step eight was fruitless.
    {Repeat Steps five through nine until death.}

    Due to the nature of the files, I can only reveal this one, since it’s already been published.
    http://prntscr.com/jmoecz
    This is pretty typical for the files I work with, though I usually also have a character list beneath prompt with reference IDs to the excel file containing their information. Nothing complex here. It’s just a text file.

    I find N++ works best for writing as I like to have offline files but don’t like paying Microsoft for that right. These files remain pretty small (the largest one I have is 5kb). I DO do HTML but that’s either being worked on or not open.

    It’s still going on right now as implied above.



  • @Loren-Fangor

    okay - now I see the issue too.
    It seems to be related to the wrapped lines functionality.
    If I disable this (View->Word Wrap) then I don’t see the jump.

    A temporary workaround might be to press the right/left cursor in that case.

    I try to investigate what is causing this.

    Cheers
    Claudia



  • Thank you! I’ll try that, though in this case it is REALLY impractical, as I rely on reading up quite often.

    Hopefully it’s a simple fix!



  • @Loren-Fangor

    just for clarification - I meant to use the workaround

    A temporary workaround might be to press the right/left cursor in that case.

    instead of disabling word wrap as I see it doesn’t make sense in your case.

    Maybe right/left arrow keys is a better description than right/left cursor

    Cheers
    Claudia



  • @Loren-Fangor

    just another idea - maybe you are already aware of - what about using the second view?
    (Right-click on the tab and choose Move to Other View)

    Cheers
    Claudia



  • Restore notepad



  • I’ve noticed the same problem as Loren describes, except for me the position is not set all the way back to the top of the file, it’s set only a few lines up from the cursor position. The cursor will be off screen (below). The left/right key workaround works, but it’s not really what we want.

    I should note that this is a recent issue, I haven’t noticed it in previous versions. Let’s hope it’s easy enough to fix. Thanks!


Log in to reply