Saving Settings



  • I seem to be having problems with my font settings for C/C++. The background seems to remember my preference, but the fonts reset every time I save and re-launch NotePad++.



  • @CodeSchlocker

    would you mind providing more details? (FAQ)

    Cheers
    Claudia



  • I didn’t really think I needed to with Saving Settings, but, perhaps that is my problem. OK. I go to Settings, Style-Configurator. I selected a Theme, in this case “Hot Fudge Sundae”. In Language, I choose C++, Style, Proprocessor Directives, Font, Consolas, Font Size 12, Color, Pink. Save and Close.

    I click out of Notepad++. None of my Settings took. I go back and repeat. No difference.



  • @CodeSchlocker

    for me it does work

    Could it be that you use enable global font… options?

    If not, can you please post your debug-info?

    Cheers
    Claudia



  • I agree.

    For me, it works during a session.

    The problem is, as I stated above, when I close out of Notepad++ and re-open it, none of my changes still exist, except for the “Select theme” value.

    I want to be able to change all the font sizes, style and color, just once, and ever time I either load C++ back into Notepad++, or write C++ in Notepad++, I want to use my modified fonts. This is how Sublime Text and CodeWriter works. I don’t have to set the font to my settings every session.

    I don’t know where to find debug info, and, I assume, it probably isn’t a bug, it’s a procedural problem on my part. I just want to know how to make my font settings permanent, that is, not just for one session.

    Also, I can’t figure out how to send screenshots with this messaging system.

    • list item


  • I can see from your screenshots above, that you are using an older version. I’m running Notepad++ v7.5.6, and you’re using 7.5.4.

    Also, as I’ve stated above, I’m modifying the settings for C++, not Global Styles. When you click on C++, Global override isn’t even displayed in the Style list.

    I do believe that, there is something wrong with my procedure, because the Font name and Font size are grayed out, even though making changes in the Font, is affecting my text in the doc. Until I close and reopen.



  • OK,

    I have a 32-bit version of v7.5.6, and it works just fine. My settings are saved when I close and re-open Notepad++.

    Maybe I should try and older 64-bit version. Something isn’t right.



  • The first image I posted shows that I changed the C++ preprocessor style.
    And it works even after restart of npp.

    The second image I posted is just for demonstrating that there is a
    global change section which affects all other styles if something is set.

    So, if you have, for example, set Enable global font in
    Global Styles->Global override your font change to consolas in
    C+±>preprocessor does not get activated.

    To post an image use this syntax ![](URL_TO_YOUR_UPLOADED_IMAGE)

    Debug-Info is under menu ?->Debug Info

    If the 32bit version works, the 64bit version should work too.

    So, at the moment, I assume it is either a global setting you have
    checked or your config file is somehow corrupted (That’s why I asked for debug-info).

    Cheers
    Claudia



  • Fantastic,

    Yeah, there is a bug in the 64-bit version of Notepad++ v7.5.6. I downloaded and installed v7.5.5, and it works just perfect.

    Not only that, it copied the settings from my 32-bit version.

    Thanks for all of your help, Claudia.

    Problem solved.


Log in to reply