I don't see the highlighting for PHP, HTML,



  • Hello,

    If I edditing a php or HTML page in Notepad++. I do not see the highlighting.
    I have look by the “Language” and everything is standing to the left under the “Available items”

    Where can I find the problem?

    I have version 7.5.6 (32-bit) is that the problem? because I have a 64 bit computer?

    Greetings,

    Jelle Ruben



  • I use 7.5.6 32bit on a 64bit OS, and I get syntax highlighting without difficulty.

    This FAQ Desk entry lists some things that may be helpful for you to tell us, so we can better help you.

    I’m not sure what you mean by “everything is standing to the left under the ‘‘Available items’’”. A screenshot (embedded with syntax like ![](https://i.imgur.com/DAwAEcI.png), but replacing with the link to your image, rather than mine) will probably help communicate your point better.

    As you can see, when I paste my ? > Debug Info > Copy to Clipboard into an HTML file, you can see syntax highlighting, even with 32bit NPP on 64bit Win10:

    And pulling down the Language menu to show the HTML entry:

    Another thing to look at is what theme you are using: Settings > Style Configurator > Select theme : – some older themes (or poorly constructed ones) have issues with certain lexers (language choices).



  • I have look at it, but PHP is select, and the text isn’t highlighting.
    screenshot



  • So you see I have select PHP language: but my text isn’t highlighting.

    With “everything is standing to the left under the ‘‘Available items’’” I mean this



  • @Jelle-Ruben ,

    First, if I’m reading those function arguments correctly, you may have accidentally revealed a password; if so, you may want to change your password (and/or edit that image to block out that portion, if it really is a password).

    As you can see in my screenshot,

    I can get PHP syntax highlighting with no problem.

    Please go to ? > Debug Info > Copy to clipboard, paste it in your reply (either indent it 4 spaces, or use the " ```z " trick mentioned in this FAQ Desk entry to help set it off from the rest of the text, though it’s not necessary). This will show us your NPP version and configuration, including plugins that might be interfering. I am using:

    Notepad++ v7.5.6   (32-bit)
    Build time : Mar 19 2018 - 00:26:59
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll dbgpPlugin.dll DSpellCheck.dll MarkdownViewerPlusPlus.dll mimeTools.dll NppConverter.dll NppExec.dll NppExport.dll NppFTP.dll PluginManager.dll PreviewHTML.dll PythonScript.dll XMLTools.dll 
    

    Also, what theme (Settings > Style Configurator > Select Theme) do you have selected? Maybe your theme has corrupted or missing PHP settings. You can also look at Settings > Style Configurator, pick php from the Languages: panel, and look at a few of the colors (for example, Style: QUESTION MARK shows a foreground of RED, as seen by the red <?php in my screenshot): maybe all those colors are set the same for you. (My theme is the default stylers.xml, but I tried Bespin, Black Board, and Choco, and they all highlighted properly, too)

    The more information you give us, the easier it is for us to help you.



  • Thanks voor you looking
    My Debug Info is :

    Notepad++ v7.5.6 (32-bit)
    Build time : Mar 19 2018 - 00:26:59
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll

    I have set the thema on Solarized-light.

    But if I select “default stylers.xml” I see stranger colours



  • Just un-tick the “enable global foreground colour” box.
    Obviously you see no highlighting because you’re overriding all color with single color.
    BTW I believe it was not so by default - so probably you have ticked this on.



  • @Mikhail-V Who thanks that was the Issue
    @PeterJones You also thanks for your help…


Log in to reply