Disappearing Snippet Libraries



  • Snippet v1.4.0 (24 May 2017) just lost every one of MY snippet Libraries.
    ► Yes, I used Snippet to “backup” my libraries.
    ► Yes, I asked Snippet to load my libraries from the backup.
    ► No, it didn’t load my snippets.
    ► Yes, I tried closing/re-opening Notepad++.
    ► Yes, I tried rebooting (cold boot) the system, and repeating the imports and restarts.
    ► Yes, if I open the backup sqlite library in ‘DB Browser for SQLite’ or 'SQLiteStudio ’ all my libraries and all my snippets are in there.
    ► Yes, I’ve uninstalled and reinstalled the Snippet plugin, and tried importing my backups.
    ► Yes, I’ve tried renaming Snippet’s “Template.sqlite” to “TemplateBKUP.sqlite” and directly copying/renaming one of my backups, and no that didn’t work.

    This isn’t the first time. When I first installed Snippets 1.4, and had added a few dozen snippets, they suddenly disappeared (before I was done entering new snippets). I learned to backup frequently when adding new snippets.

    This is, however, the first time they’ve disappeared since I “learned to backup frequently” and is the first time I’ve tried to import libraries. So it looks like I’ve learned another important lesson: Snippets is unreliable and absolutely not worth the effort.

    Unless someone has an idea that fixes it.



  • Are you talking about https://github.com/ffes/nppsnippets/releases/tag/v1.4.0 ? In this case you may want to create a bugreport at https://github.com/ffes/nppsnippets/issues



  • Done. Thanks! I’ll let you know if I hear anything useful.

    https://github.com/ffes/nppsnippets/issues/17



  • Addendum: Suddenly, after at least 2 computer reboots, untold multiple open and closes of NPP, and 2 days later, not only are my snippets back but I now have a copy for each and every attempt to import them!

    I have updated my support ticket, along with a screen shot.



  • Seriously - I closed NPP. I re-opened it. My snippets are GONE, again! In less than 2 minutes.


Log in to reply