Failed to Load Error - every launch (CSScriptNpp.x86.dll)



  • Hi,

    Each time I launched Notepad++, I got the error pop up:

    Failed to load

    CSScriptNpp.x86.dll is not compatible with current version of Notepad++.

    Do you want to remove this plugin from plugins directory to prevent this message from next launch?

    Clicking “yes” did NOT remove the plugin & message would appear at next launch. Rinse, repeat.

    I tried:

    • Running Notepad++ with Admin rights. Got error message & again it failed removed the plugin.

    • Using Plugin Manager to try & remove plugin. But, each time I tried to open the manager, Notepad++ crashed to desktop

    What finally worked was using File Explorer to navigate to the plugins folder & manually moving the offending dll out of the folder. Once I did this no error message & plugin manager now works.



  • @glasco61 said:

    What finally worked was using File Explorer to navigate to the plugins folder & manually moving the offending dll out of the folder. Once I did this no error message & plugin manager now works.

    If you didn’t have the above in your post, it’s what I would have suggested to try. I’d say “problem solved” or is there something else I’m not seeing here?



  • I had the same error and reported an issue at CS-Script’s project page. The plugin author fixed it by releasing version 1.7.13.0. It should be available via PluginManagers developer plugin list.

    The release note states:

    This release is just repackaged v1.7.12.0. repackaging was required due to the Notepad++ v7.5.7 suddenly changing the hosting model, which is no longer allowing plugin entry dll to have the name that is even slightly different to the plugin name.


Log in to reply