NP++ 'ignores' parenthesis in remote session while editing Python



  • Hello,

    I’m running NP++ on an Ubuntu 16.04 LTS machine. Due to lack of physical space for yet another keyboard and monitor, I’ve been accessing the machine via VNC Viewer on a Win10 x64 Pro machine.

    NP++ will allow the entry of ( or ) if I use the keyboard for the Ubuntu machine. But, remotely, when I attempt to use ( or ) nothing happens…

    Is this a setting that I’m missing?

    As a point of reference, I can use gedit remotely without any issues.

    VNC Viewer version 6.18.625

    Edit:
    I forgot, the NP++ was installed using the Ubuntu software ‘store’ and is version 7.5.8 and is showing 32-bit.

    Of course I can get the task done with gedit, but I can be more productive using NP++.

    Thank you in advance for your suggestions,



  • @Chip-Wachob

    is it possible that the keyboard layout changes when wine applications are used?
    Is ubuntu running on a physical machine or is it a virtual server instance?

    Cheers
    Claudia



  • That sounds like a convoluted mess. It’s probably nothing inherent to any one piece of the puzzle, but probably has to do with subtle interactions between them.

    I have no way to replicate that setup, so I cannot help you directly. However, a couple of debug hints that I could think of:

    Have you tried any other “target” apps other than Notepad++ and gedit? Anything else that uses the GUI more in depth, like LibreOffice Writer/Calc or something like that. If you have tried, do the parentheses make it through to those apps? (About all I can think of is that gedit is such a “lite” application that it doesn’t have delays, but trying to run Notepad++ through whatever WINE or other wrapper that Ubuntu is using to run a windows application is causing enough processing ‘glitches’ that happen to be missing when you’re typing those characters.)

    And, as an alternative procedure:

    Personally, I would run Notepad++ on your Win10 machine, and use the NppFTP plugin to remotely edit files that are on your Ubuntu box. That way, NPP is in its native Windows environment, and there is no keyboard disconnect, and you aren’t worrying about live GUI signals across the VNC connection. The only major network transactions involved will be when trying to save the file across the network (ie, sftp transfers)… and that’s much less of a problem, I think. But that’s just my advice.



  • Claudia,

    The Ububtu is running on a physical machine.

    Peter,

    Yes, agreed, a mess, but it was the quickest way I knew to get up and running given the limited space.

    I just tested both Calc and Writer and both were completely happy with me typing ( or ). There did not appear to be any delays.

    I believe that I saw something pop up briefly about Wine. So, my guess is that you’re right there’s another layer of complication there.

    I’ll look into the NppFTP plugin and see if I can get that working smoothly.

    I knew that I’d get some good suggestions.

    There is no ‘native’ NP++ binary for Ubuntu, correct?



  • No, there is no native NPP binary for Ubuntu.

    Since the native-linux Calc/Writer worked just fine, I’m pretty confident at this point that your parentheses are getting lost in Wine. If you had another windows-based application that you could run in Win, if it lost the parentheses, too, that would boost the confidence that it’s the Wine that’s drinking your characters.

    But I still think NppFTP is your best bet.

    Failing NppFTP (some SFTP servers no longer play well with NppFTP, because they’ve dropped support for some of NppFTP’s older encryption algorithms): try running FileZilla on Windows, with FileZilla’s Edit > Settings > Editing > ☑ Use custom editor "C:\Program Files (x86)\Notepad++\notepad++.exe" (including quotes, if there’s a space in the path); then you can right click the remote file in FileZilla, and it will open up your Windows’ Notepad++ for doing the editing; whenever you save in NPP, then FZ will ask if you want to upload, and if you’re done (you can upload on every save; only tell it you’re done on the final save).



  • Thanks to all.

    Just got Npp with NppFTP plugin working. The ‘help’ for NppFTP is a little light, but once you set up your ‘server’ in NppFTP and click on the chain link, you are good to go…

    Used vsftpd and xinetd per here

    https://linuxconfig.org/how-to-setup-and-use-ftp-server-in-ubuntu-linux

    On the Ubuntu side.


Log in to reply